• Hi Guest, welcome to TCG 2.0. Please refer to the FAQ in User Support before you do anything else. It will make the transition MUCH easier.

    IF YOU ARE SEEING AN "OOPS" ERROR PAGE, IT IS LIKELY BECAUSE YOUR BROWSER HAS NOT UPDATED YOUR CACHE. YOU CAN EITHER CLICK FORUMS AT THE TOP LEFT OR VISIT THECHICAGOGARAGE.COM AND BOOKMARK THAT. - Love, Mook

The Road is still going...

syP

Not Banned
Joined
May 24, 2007
Messages
29,891
Reaction score
15
Location
Downers Grove, Illinois
I have decided to keep the Grand Prix and throw a stock l67 longblock into it from Ed Morad. I guess you dont really know how knowledgable a person is and how much they want to help you out until you talk to them on the phone about your dilema. I have never talked to ED before other than a few Emails here and there... But we did talk on the phone and sorted things out with the engine.

I believe it is a 1999 l67 with 90kmiles on it... IT runs flawlessly as Ed says... EVERYTHING is bone stock on it.

However... i will not be having it stock when i put it in...


The parts i have laying around are:

TOG Headers (I dont have stock manifolds)
42.5lb injectors (i dont have stock)
DHP (I dont have stock)
Intake (I dont have stock)
Exhaust (why put on stock?)
180* tstat.


As of now.. after driving it stock for a while.. i plan on doing light mods.. such as a 3.4" then Rockers... all scanning with HEAVYKEVY's Ls1m (i sold it to him) to make sure i got no knock..

I will then put alky on it and hopefully should be in the 12s by then with some decent rubber and the obvious smaller (no kr) pulley.


Thanks guys for keepin my head up in this damn situation i am in. Especially thanks to Ed Morad.

Expect videos
 
I

imported_GraFFix

Guest
90k is pretty high milage..Dont know if I would do it myself. Im looking for something under 50k for a swap...anyone?? but good luck either way.
 

smug

Please go back to eating crayons
Joined
Aug 4, 2007
Messages
7,063
Reaction score
2
Location
Cedar Lake, IN
Im glad that you are keeping you car. 90K does seem a tad high on miles, but it was a stock 3.8 so it should be good. I have a 98 regal GS in my body shop with 178,500 miles on it and it runs perfect, except the oil pan and valve cover gaskets are leaking bad on it.
 

Royalgtp

Well-known member
Joined
Dec 24, 2008
Messages
3,700
Reaction score
0
Just remember that going fast cost money and you gotta pay to play.

GL
 

xierxior

Well-known member
Joined
Feb 2, 2008
Messages
834
Reaction score
0
Location
chicago
90k is not high my car has 123k I had to rebuild the suspension but the motor runs like its brand new.. I even did a leakdown test :) I had a van I used to use for work that had like 380k on it... I beat the living piss out of that van all day long to.. like putting 5340 pounds in it and having it nailed all the way down the onramp to the highway.. :lolsign:

edit: I did manage to blow the T400 trans in the van tho.. er.. twice :lolsign:
 

gtphale

Well-known member
Joined
Nov 9, 2008
Messages
1,578
Reaction score
0
Location
Aurora
don't do alky injection. keep the intercooler and put that on it.
 

Sinister Drag Designs

SinisterDragDesigns.com
Joined
Aug 3, 2007
Messages
4,876
Reaction score
0
Location
Chicago, IL
Originally posted by gtphale@Nov 30 2005, 05:49 PM
don't do alky injection. keep the intercooler and put that on it.
[snapback]105458[/snapback]​

so are all the sales off i was looking forward to that stuff? :eek: :unsure:
 

syP

Not Banned
Joined
May 24, 2007
Messages
29,891
Reaction score
15
Location
Downers Grove, Illinois
Looks like it :(

HAle.. i had to sell the IC to get my Funds..


i will most likely be buying one in the future...

why do you say no to ALky?
 

gtphale

Well-known member
Joined
Nov 9, 2008
Messages
1,578
Reaction score
0
Location
Aurora
to many tuning problems and its a band aid not a correct way to mod. Ash Nick what he thinks of Alky injection. You will hydro lock your motor with it.
 

Fish

From the mean streets....
Joined
Aug 3, 2007
Messages
36,113
Reaction score
21
Location
Chiraq
Ive only been around since 03, but W/I has been brought up a few times over the years. Yeah people post results, but at the end, its all a joke.

Im sure Hale has seen it brought up more than I have.
 

Sinister Drag Designs

SinisterDragDesigns.com
Joined
Aug 3, 2007
Messages
4,876
Reaction score
0
Location
Chicago, IL
Originally posted by Fish@Nov 30 2005, 10:32 PM
Ive only been around since 03, but W/I has been brought up a few times over the years. Yeah people post results, but at the end, its all a joke.

Im sure Hale has seen it brought up more than I have.
[snapback]105494[/snapback]​
will u still sell the 3.0 pulley?
 
S

sr71_rgl

Guest
Originally posted by gtphale@Nov 30 2005, 09:15 PM
to many tuning problems and its a band aid not a correct way to mod. Ash Nick what he thinks of Alky injection. You will hydro lock your motor with it.
[snapback]105487[/snapback]​

My car ran fine for the 3 days the w/i was functional. After inspecting parts from my original motor after #2 X-valve broke I'd think its safe to say w/i wasn't really a factor. Bottom line was my motor was on borrowed time because the PnP heads I bought weren't set up right during assembly. It gave up the ghost under a healthy shot of alky but only rolling into the throttle...not wot which tells me it a weak point was exposed. All the exhaust valves on both heads were loose and would wiggle in the guides..the intakes had no such slop. I should have caught on to this due to all the drivetrain noise my car made. I thought it was noisy injectors or the oversized valves but it was more than likely the loose X valves. The heads I'm running now were set up proper and don't make any noise at idle. I think w/i has its place as a poor man's i/c but I stress only use enough to kill the kr. I'm gonna try it again when the weather warms up and see how the motor likes it.
 

Sinister Drag Designs

SinisterDragDesigns.com
Joined
Aug 3, 2007
Messages
4,876
Reaction score
0
Location
Chicago, IL
Originally posted by sr71_rgl+Dec 1 2005, 03:04 PM-->
<!--QuoteBegin-gtphale
@Nov 30 2005, 09:15 PM
to many tuning problems and its a band aid not a correct way to mod. Ash Nick what he thinks of Alky injection. You will hydro lock your motor with it.
[snapback]105487[/snapback]​

My car ran fine for the 3 days the w/i was functional. After inspecting parts from my original motor after #2 X-valve broke I'd think its safe to say w/i wasn't really a factor. Bottom line was my motor was on borrowed time because the PnP heads I bought weren't set up right during assembly. It gave up the ghost under a healthy shot of alky but only rolling into the throttle...not wot which tells me it a weak point was exposed. All the exhaust valves on both heads were loose and would wiggle in the guides..the intakes had no such slop. I should have caught on to this due to all the drivetrain noise my car made. I thought it was noisy injectors or the oversized valves but it was more than likely the loose X valves. The heads I'm running now were set up proper and don't make any noise at idle. I think w/i has its place as a poor man's i/c but I stress only use enough to kill the kr. I'm gonna try it again when the weather warms up and see how the motor likes it.
[snapback]105573[/snapback]​
[/b]
thats true, im just trying to kill a few degrees of knock, ....speaking of my devil's own kit doesnt have any instructions, can anyone give me instructions or help put it on id like gp specific instrctions if anyone has any, or can think of how they did it, im tappin my tb if that helps
thanks
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom