GTPpower's 05 F-350 6.0 PSD

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
I need a way to help me keep track of everything I'm doing to this thing.



I bought it from a dealer on 02/01/17. It needed an oil cooler and possibly a headgasket. I farm and own a construction business, so reliability is a main concern. I took it to a diesel shop a few weeks later to get the following done.

-Headstuds
-EGR Delete
-4" Turboback Exhaust
-Edge CTS2 Pro with Gearhead Custom tuning
-Edge EGT Probe
-Mishimoto Coolant Filter
-Valvecover Gaskets
-Rear Main Seal
-Updated Oil Cooler
-Rear Cover Gasket
-Updated Turbo Feed Line
-Rocker Box Gasket
-Injector O-ring kit
-Heater Tube O-ring
-Motorcraft Crank Sensor
-Passanger and Driver Glow Plug Harnesses
-Hpop Gasket Kit
-Updated Turbo Oil Drain
-Standpipe & Dummy Plug Kit
-Blue Spring Kit
-6.4 Pushrods
-6.4 Lifters
-Cam position sensor
-Racor Oil and Fuel Filters
-5w-40 Synthetic Oil
-CAT Extended Life Coolant
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
I had a problem with the coolant filter leaking at the fittings.



I tried some pipe dope on them. They leaked less, but still some.

I took the fittings back out again and used permatex thread sealant HEAVILY on the threads. It appears to have fixed my problem.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
It is close to 5k miles since I picked it up from the shop, so I'm collecting parts for maintence.



Engine and Transmission Filters


Went ahead and bought a case of this.



Here is what I decided to use for oil.


I also have a blackstone kit for sampling oil, so I will be sending a sample in.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
There also is a leveling kit on it...looks like about 2" spacers.



It needs new shocks, so I'm debating if I want to keep the level kit or not. I don't really want to put bigger tires on it, so I may try to track down stock spacers and bolts.
 

Yaj Yak

Harbor Master
Donating Member
Joined
May 24, 2007
Messages
90,313
Reaction score
1,207
this is awesome

i didnt know you finally got one

:bigthumb:
 

DEEZUZ

Escrow shortage crew
Donating Member
Joined
Nov 20, 2008
Messages
44,727
Reaction score
655
Location
NWI
Needs more manual transmission
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
Saturday I got some work done. Dropped the pan, which was surprisingly clean.



The filter was black, but had almost no buildup on it.



There was a little clutch material on the magnet. Cleaned it up and got it ready to reinstall.





I also drained the engine oil.



I took a sample and will be sending it to Blackstone.

I put in 15 quarts of synthetic 5w-40 and two bottles of this.


It also ended up taking 8.5 bottles of this trans fluid, and I still think it's a little bit low.
 

10sec

I haz dat teddy bear smile.
Donating Member
Joined
Jul 26, 2008
Messages
23,363
Reaction score
128
Awesome, doin' work. I love threads with a bunch of pics!
 

Outlaw

Well-known member
Joined
Jul 24, 2009
Messages
15,635
Reaction score
8
Location
Johnsburg
-Headstuds
-EGR Delete
-4" Turboback Exhaust
-Edge CTS2 Pro with Gearhead Custom tuning
-Edge EGT Probe
-Mishimoto Coolant Filter
-Valvecover Gaskets
-Rear Main Seal
-Updated Oil Cooler
-Rear Cover Gasket
-Updated Turbo Feed Line
-Rocker Box Gasket
-Injector O-ring kit
-Heater Tube O-ring
-Motorcraft Crank Sensor
-Passanger and Driver Glow Plug Harnesses
-Hpop Gasket Kit
-Updated Turbo Oil Drain
-Standpipe & Dummy Plug Kit
-Blue Spring Kit
-6.4 Pushrods
-6.4 Lifters
-Cam position sensor
-Racor Oil and Fuel Filters
-5w-40 Synthetic Oil
-CAT Extended Life Coolant
What'd that whole pile of work run? If I go the 6.0 route I'm sure this will be pretty quick to follow.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
Right around $6600 installed. The exhaust, tuner, and egt probe was around $1200 by themselves.

But I did price shop around though. Another place was about $8k for all this. Another was over $10k.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
I've been having issues with the turbo not boosting for a minute or 2 after heavy throttle. Thought it was in the tune, but after talking to Matt at gearhead, I don't think it is. I've also been noticing that boost is maybe not quite as high as it was.

Anyways, I was coming home late last night and the road was empty. So I thought I would try the 1/4 mile test on the cts2. I just launched it 2wd. When the turbo lit, it blew the tires off, but I ended up with this.



Anyways I let off and waited for the turbo to spool back up. About ten minutes later when I pulled into my driveway, vgt was still at 85%. I looked at the cac tubes and everything seems fine. I shut it off and restarted it without any change. So it looks like the turbo is stuck.

I need to pull it off and clean it from what I can find online. But what do I need to get for parts? It looks like there are some seals and orings that need replaced.

Is there anything else I should check?
 

DEEZUZ

Escrow shortage crew
Donating Member
Joined
Nov 20, 2008
Messages
44,727
Reaction score
655
Location
NWI
Right now I cant say the turbo is stuck from what you have provided.

Keep in mind that the 85% that your reading, is not measuring the actuator travel. thats what the PCM is commanding. On the Duramax, it has a sensor that measures this travel and makes it super easy to dio a stuck turbo.

This seems like there is intake leak of some sort as its maxing the turbo out to make up the EBP and MAP it needs to see.
 

DEEZUZ

Escrow shortage crew
Donating Member
Joined
Nov 20, 2008
Messages
44,727
Reaction score
655
Location
NWI
are you hearing any sort of fluttering or turbo farting on raid decel? If you're buidling boost and let off the throttle, does it make a sound?

Also, with KOEO, what do al the pressure PIDs read? MAP, BARO, MGP, EBP
 

DEEZUZ

Escrow shortage crew
Donating Member
Joined
Nov 20, 2008
Messages
44,727
Reaction score
655
Location
NWI
Parts list is just the 2 turbo drain seals, w300012, turbo oil feed seal and gasket.

Although they should be all new and if you could keep the turbo oil line attatched to the turbo you shouldnt have to buy any provided you dont tear the drain seal on install.

Nothing is needed for the cleaning of the turbo unless you find a cracked unison ring. Just time, cleaning materials.

You do know you can get a brand new turbo for these things for ~$800....

I only clean turbos for side jobs, never in shop. The clean may last 6 weeks or 6 months. Alot of my customers want it done right and want zero down time
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
It may slightly flutter on rapid decel, but it's not very noticeable. I've only heard it a few times.

Speaking of leaks, I was going to take off the boots and clean them...the clamps were super loose yesterday morning, so I tightened them up. But I think I should just take them off and clean it up good.

I will log all that stuff, but might have to wait til tomorrow to check it out.

I have to run to omaha today, so I may try to see if an auto parts store has the parts I need.

And, yeah I see that stock turbos are cheap. If it's bad though, I think I may just shell out $300 more for the powermax.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
What is mgp?

This is with koeo.


Cruising at 60mph, not much changes. Map goes to 14, and ebp goes to 1.

I did gun it, and it built 22-23 psi. But after letting off, no boost and vgt back to 85%.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
I went back to the stock tune just to check if it wasn't a tune problem and so it would quit blowing black smoke on my test drives. Nothing changed. But I did floor it from 5mph. Vgt stayed at 85% the whole time. It didn't build any boost til 2nd gear when it peaked at 17 psi. I let off, and vgt decreased to about 50%, but quickly went back to 85%.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
I went and unplugged the ebp sensor while just letting it idle in my driveway. On the scanner, ebp went to 36psi. From what I understand, that's in the computer programing for a sensor failure. After plugging it back in, it went back to zero.

Also, the VGT changed to ~45%. However, the exhaust note did not change. No whistle....it sounds like a Cummins.

I'm not getting a CEL, but I did check codes after all this. I got a code for the EBP sensor....I'm guessing from unplugging it. I also pulled a PO046 - Turbo/Super Charger Boost Control Solenoid Circuit Range/Performance.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
Fixed it!

Pulled the CAC tube off to clean it up and inspect the boots. No big holes, but I think I'll be replacing the upper before too long.


But I was checking the wires over for the vgt, and the plug just fell out. The clip was broken. Plugged it back in, and all seems normal now.


I'll have to get a small zip tie and tighten it down.

Now with koeo, ebp is at 5psi. Map and baro are right at 14. Is the still a problem there?
 

DEEZUZ

Escrow shortage crew
Donating Member
Joined
Nov 20, 2008
Messages
44,727
Reaction score
655
Location
NWI
KOEO means key on engine off.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
Yeah I know that.

I'm thinking that there is a problem with the ebp sensor according to some dieseltechron videos. He is saying that ebp and map should be very close. Mine are not.

It also doesn't have as much power as it did when I first got it. On the extreme tune, it blows a decent amount of black smoke when I floor it.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
Changed the coolant filter. There was about 6500 miles on it.





I dumped the old filter out. There was a lot of crap in it.



I'm not real sure what that is. It's all pretty dark in color.
 

DEEZUZ

Escrow shortage crew
Donating Member
Joined
Nov 20, 2008
Messages
44,727
Reaction score
655
Location
NWI
Casting sand. Cut the filter open next. That's alot for having all that work done... Don't be surprised if your oil cooler restricts a tad with all they left in the system

After seeing that I'd go 2x or 3x the milege on next filter. After that once a year.
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,280
Reaction score
83
Location
Nebraska
Crazy how the oil cooler has been replaced twice on here, and there is still all that sand. I still have the filter...should I cut it open?

My deltas still look good. 8°is about the biggest difference i see.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom