Stock Head unit Question

PNSH3R

Well-known member
Joined
Mar 7, 2008
Messages
313
Reaction score
0
Ok,
I need some help figuring out what went wrong here. I purchased a mach 460 head unit a couple of days ago, to replace the aftermarket unit that was in the car. I get the unit in, and I am thinking that it will be just plug and play - being it is original equipment, but I guess not....
Is this head unit from a different model? Any info will be greatly appreciated.
Btw, this is in a 2003 10th anniv coupe

 

RAPER

Well-known member
Joined
Jan 12, 2008
Messages
324
Reaction score
0
Location
Rockford-ish
those harness sockets on the back look like the older ford ones.. i'm not sure when they changed the wiring but those look similar to the wiring on the 99-00 models, but those where duel single din units... factory loves changing harness on people
 

ShelbyGuy

Turgid Member
Joined
Mar 26, 2004
Messages
5,231
Reaction score
0
Its neither an 03 nor an 04 mach460.
ok it MIGHT be an 04 but i doubt it. 03 and 04 are different and don't interchange.
 

serb82

Well-known member
Joined
Feb 10, 2009
Messages
1,075
Reaction score
1
The harness of your new radio is for 04+ model year fords. They started to use in the f-150 in 04 and explorer. The harness for your car is from 98-03. Since the mustang/cobra was the last year for 04 they just used the old style harness. No need to change radio wiring when it was the last model year of that car. For the mustang mach 460 unit, you can use anything from 01-04. 00 and older are differnt for mustang.

If memory serves me right, been over a year since done installations, the medium size plug is your main power/ground connections and tweeter wires The Small one is for the mach 460 amps which power the rear deck and front doors. You can use that radio if you want by purchasing 2 harness from metra 1 to plug into factory car harness (70-1771) other to plug into other factory radio (71-5520-1) costing anywhere from 40-60 for both. Or using the 71 style harness and splicing in factory wires.

Hope I didnt confuse you and that helps.
 
OP
P

PNSH3R

Well-known member
Joined
Mar 7, 2008
Messages
313
Reaction score
0
Thanks for the info guys. It definitely seems to be a headunit from a different car.

I looked up the part number on the side of the radio and it is 3L1T-18C815-AA , and it turns out it is Expedition radio. I PMd the seller & we'll see how we can fix this. He is a member on the board here, and I am hoping that everything will be fixed easily. Could be just a simple mistake (he did say that he had another headunit).
So, we'll just try and work it out without any names being mentioned. GUy was easy to deal with and very fast shipping. :)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom