01 grand am trans issue

CrawlinTBSS

Detailer
Joined
Jul 8, 2007
Messages
4,355
Reaction score
0
Location
Naperville, IL
Had a neighbor bring a car by they just bought and trans was acting up. Its hanging in gear, rides out to like 4k or if u let off itll shift.

2001 Grand am 2.4l.

Partner did a drain and fill with new filter yesterday. Said it drove fine after and now this morning customer says its even worse. Did a test drive and its clunking/thumping hard wheen shifting. 1-2 and 2-3 shift wont shift til like 4k again. And when you let off the gas i get that hard clunk aswell.

Something internal? Alldata has a tsb on hard shift that has to due with bore pressure valve.

Car also has codes for wheel speed sensor reading 0 and the trac off light is on. Customer saidsays it drove ok when the trac light wasnt on and then it came on yesterday and is driving horrible again. Could the WSS be affecting it or am i looking at something internal? And maybe dealership masked it to sell the car.
 

daturbosix

Forum Sponsor
TCG Sponsor
Joined
Mar 2, 2008
Messages
11,778
Reaction score
170
Location
Aurora
perfect reason i will never change somebodys dirty trans fluid.

but... wss communicate shift points. so yes. its possible its just a fluke.
 

CrawlinTBSS

Detailer
Joined
Jul 8, 2007
Messages
4,355
Reaction score
0
Location
Naperville, IL
Just cleared the codes and now it drives fine and doesnt turn any back on. It didnt have WSS this time. Just pcm disabled TC or something.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom