Forum Register Members Casino Live Posting Feed Garage Arcade iTrader Members List Calendar Search Today's Posts Mark Forums Read
Go Back   The Chicago Garage > Community > Member Rides & Sightings
speed

User Tag List

Like Tree72Likes

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-28-2017, 12:48 PM   #1
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default GTPpower's 05 F-350 6.0 PSD

I need a way to help me keep track of everything I'm doing to this thing.



I bought it from a dealer on 02/01/17. It needed an oil cooler and possibly a headgasket. I farm and own a construction business, so reliability is a main concern. I took it to a diesel shop a few weeks later to get the following done.

-Headstuds
-EGR Delete
-4" Turboback Exhaust
-Edge CTS2 Pro with Gearhead Custom tuning
-Edge EGT Probe
-Mishimoto Coolant Filter
-Valvecover Gaskets
-Rear Main Seal
-Updated Oil Cooler
-Rear Cover Gasket
-Updated Turbo Feed Line
-Rocker Box Gasket
-Injector O-ring kit
-Heater Tube O-ring
-Motorcraft Crank Sensor
-Passanger and Driver Glow Plug Harnesses
-Hpop Gasket Kit
-Updated Turbo Oil Drain
-Standpipe & Dummy Plug Kit
-Blue Spring Kit
-6.4 Pushrods
-6.4 Lifters
-Cam position sensor
-Racor Oil and Fuel Filters
-5w-40 Synthetic Oil
-CAT Extended Life Coolant
__________________
05 F350 6.0 - studded, deleted, bulletproofed, tuned
01 GTP - Slicks/Skinnies/Nitrous/Stock Trans - [email protected] Sold
66 442 Vert - Needs work
00 Silverado 2500 - 6.0 Junk
GTPpower is online now   Reply With Quote
Old 04-28-2017, 12:50 PM   #2
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

I had a problem with the coolant filter leaking at the fittings.



I tried some pipe dope on them. They leaked less, but still some.

I took the fittings back out again and used permatex thread sealant HEAVILY on the threads. It appears to have fixed my problem.
GTPpower is online now   Reply With Quote
Old 04-28-2017, 12:53 PM   #3
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

It is close to 5k miles since I picked it up from the shop, so I'm collecting parts for maintence.



Engine and Transmission Filters


Went ahead and bought a case of this.



Here is what I decided to use for oil.


I also have a blackstone kit for sampling oil, so I will be sending a sample in.
GTPpower is online now   Reply With Quote
Old 04-28-2017, 12:53 PM   #4
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

There also is a leveling kit on it...looks like about 2" spacers.



It needs new shocks, so I'm debating if I want to keep the level kit or not. I don't really want to put bigger tires on it, so I may try to track down stock spacers and bolts.
CTC DEEZUL likes this.
GTPpower is online now   Reply With Quote
Old 04-28-2017, 12:56 PM   #5
Harbor Master
 
Yaj Yak's Avatar
 
Join Date: May 2007
Posts: 71,575
Casino cash: $130059601
18.54 per day
Mentioned: 1136 Post(s)
Tagged: 3 Thread(s)
Send a message via AIM to Yaj Yak
Default

this is awesome

i didnt know you finally got one

GTPpower likes this.
__________________
01 525i
01 turbo pricks
13 gas 3500hd cclb

Ridgeline humper.
Yaj Yak is online now   Reply With Quote
Old 04-28-2017, 01:28 PM   #6
WWMoMD
 
CTC DEEZUL's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 30,955
Casino cash: $128220000
9.34 per day
Mentioned: 381 Post(s)
Tagged: 0 Thread(s)
Default

Needs more manual transmission
GTPpower likes this.
__________________

Quote:
Originally Posted by Mr.bu View Post
I had a girl like that once. Everytime I put my hand down her pants, it felt like feeding oats to a horse.
Quote:
Originally Posted by Eagle View Post
THIS IS TCG, DOES IT LOOK LIKE WE CARE WHAT IT COSTS!??!?!


CTC DEEZUL is online now   Reply With Quote
Old 04-28-2017, 01:33 PM   #7
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

I tried really hard to find one.
GTPpower is online now   Reply With Quote
Old 05-01-2017, 07:27 AM   #8
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

Saturday I got some work done. Dropped the pan, which was surprisingly clean.



The filter was black, but had almost no buildup on it.



There was a little clutch material on the magnet. Cleaned it up and got it ready to reinstall.





I also drained the engine oil.



I took a sample and will be sending it to Blackstone.

I put in 15 quarts of synthetic 5w-40 and two bottles of this.


It also ended up taking 8.5 bottles of this trans fluid, and I still think it's a little bit low.
Yaj Yak and RICH17 like this.
GTPpower is online now   Reply With Quote
Old 05-01-2017, 09:04 AM   #9
I haz dat teddy bear smile.
 
10sec's Avatar
 
Join Date: Jul 2008
Posts: 20,319
Casino cash: $58747925
5.92 per day
Mentioned: 156 Post(s)
Tagged: 8 Thread(s)
Default

Awesome, doin' work. I love threads with a bunch of pics!
Yaj Yak and GTPpower like this.
__________________
2005 S2000
10sec is online now   Reply With Quote
Old 05-01-2017, 11:02 AM   #10
 
Outlaw's Avatar
 
Join Date: Jul 2009
Location: Johnsburg
Posts: 13,990
Casino cash: $52612800
4.56 per day
Mentioned: 557 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by GTPpower View Post
-Headstuds
-EGR Delete
-4" Turboback Exhaust
-Edge CTS2 Pro with Gearhead Custom tuning
-Edge EGT Probe
-Mishimoto Coolant Filter
-Valvecover Gaskets
-Rear Main Seal
-Updated Oil Cooler
-Rear Cover Gasket
-Updated Turbo Feed Line
-Rocker Box Gasket
-Injector O-ring kit
-Heater Tube O-ring
-Motorcraft Crank Sensor
-Passanger and Driver Glow Plug Harnesses
-Hpop Gasket Kit
-Updated Turbo Oil Drain
-Standpipe & Dummy Plug Kit
-Blue Spring Kit
-6.4 Pushrods
-6.4 Lifters
-Cam position sensor
-Racor Oil and Fuel Filters
-5w-40 Synthetic Oil
-CAT Extended Life Coolant
What'd that whole pile of work run? If I go the 6.0 route I'm sure this will be pretty quick to follow.
Outlaw is offline   Reply With Quote
Old 05-01-2017, 02:43 PM   #11
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

Right around $6600 installed. The exhaust, tuner, and egt probe was around $1200 by themselves.

But I did price shop around though. Another place was about $8k for all this. Another was over $10k.
Outlaw likes this.
GTPpower is online now   Reply With Quote
Old 05-06-2017, 10:31 AM   #12
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

I've been having issues with the turbo not boosting for a minute or 2 after heavy throttle. Thought it was in the tune, but after talking to Matt at gearhead, I don't think it is. I've also been noticing that boost is maybe not quite as high as it was.

Anyways, I was coming home late last night and the road was empty. So I thought I would try the 1/4 mile test on the cts2. I just launched it 2wd. When the turbo lit, it blew the tires off, but I ended up with this.



Anyways I let off and waited for the turbo to spool back up. About ten minutes later when I pulled into my driveway, vgt was still at 85%. I looked at the cac tubes and everything seems fine. I shut it off and restarted it without any change. So it looks like the turbo is stuck.

I need to pull it off and clean it from what I can find online. But what do I need to get for parts? It looks like there are some seals and orings that need replaced.

Is there anything else I should check?
GTPpower is online now   Reply With Quote
Old 05-06-2017, 10:58 AM   #13
WWMoMD
 
CTC DEEZUL's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 30,955
Casino cash: $128220000
9.34 per day
Mentioned: 381 Post(s)
Tagged: 0 Thread(s)
Default

Right now I cant say the turbo is stuck from what you have provided.

Keep in mind that the 85% that your reading, is not measuring the actuator travel. thats what the PCM is commanding. On the Duramax, it has a sensor that measures this travel and makes it super easy to dio a stuck turbo.

This seems like there is intake leak of some sort as its maxing the turbo out to make up the EBP and MAP it needs to see.
CTC DEEZUL is online now   Reply With Quote
Old 05-06-2017, 11:00 AM   #14
WWMoMD
 
CTC DEEZUL's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 30,955
Casino cash: $128220000
9.34 per day
Mentioned: 381 Post(s)
Tagged: 0 Thread(s)
Default

are you hearing any sort of fluttering or turbo farting on raid decel? If you're buidling boost and let off the throttle, does it make a sound?

Also, with KOEO, what do al the pressure PIDs read? MAP, BARO, MGP, EBP
CTC DEEZUL is online now   Reply With Quote
Old 05-06-2017, 11:04 AM   #15
WWMoMD
 
CTC DEEZUL's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 30,955
Casino cash: $128220000
9.34 per day
Mentioned: 381 Post(s)
Tagged: 0 Thread(s)
Default

Parts list is just the 2 turbo drain seals, w300012, turbo oil feed seal and gasket.

Although they should be all new and if you could keep the turbo oil line attatched to the turbo you shouldnt have to buy any provided you dont tear the drain seal on install.

Nothing is needed for the cleaning of the turbo unless you find a cracked unison ring. Just time, cleaning materials.

You do know you can get a brand new turbo for these things for ~$800....

I only clean turbos for side jobs, never in shop. The clean may last 6 weeks or 6 months. Alot of my customers want it done right and want zero down time
CTC DEEZUL is online now   Reply With Quote
Old 05-06-2017, 11:33 AM   #16
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

It may slightly flutter on rapid decel, but it's not very noticeable. I've only heard it a few times.

Speaking of leaks, I was going to take off the boots and clean them...the clamps were super loose yesterday morning, so I tightened them up. But I think I should just take them off and clean it up good.

I will log all that stuff, but might have to wait til tomorrow to check it out.

I have to run to omaha today, so I may try to see if an auto parts store has the parts I need.

And, yeah I see that stock turbos are cheap. If it's bad though, I think I may just shell out $300 more for the powermax.
GTPpower is online now   Reply With Quote
Old 05-07-2017, 08:04 PM   #17
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

What is mgp?

This is with koeo.


Cruising at 60mph, not much changes. Map goes to 14, and ebp goes to 1.

I did gun it, and it built 22-23 psi. But after letting off, no boost and vgt back to 85%.
GTPpower is online now   Reply With Quote
Old 05-07-2017, 08:29 PM   #18
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

I went back to the stock tune just to check if it wasn't a tune problem and so it would quit blowing black smoke on my test drives. Nothing changed. But I did floor it from 5mph. Vgt stayed at 85% the whole time. It didn't build any boost til 2nd gear when it peaked at 17 psi. I let off, and vgt decreased to about 50%, but quickly went back to 85%.
GTPpower is online now   Reply With Quote
Old 05-07-2017, 10:14 PM   #19
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

I went and unplugged the ebp sensor while just letting it idle in my driveway. On the scanner, ebp went to 36psi. From what I understand, that's in the computer programing for a sensor failure. After plugging it back in, it went back to zero.

Also, the VGT changed to ~45%. However, the exhaust note did not change. No whistle....it sounds like a Cummins.

I'm not getting a CEL, but I did check codes after all this. I got a code for the EBP sensor....I'm guessing from unplugging it. I also pulled a PO046 - Turbo/Super Charger Boost Control Solenoid Circuit Range/Performance.
GTPpower is online now   Reply With Quote
Old 05-08-2017, 10:16 AM   #20
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

Fixed it!

Pulled the CAC tube off to clean it up and inspect the boots. No big holes, but I think I'll be replacing the upper before too long.


But I was checking the wires over for the vgt, and the plug just fell out. The clip was broken. Plugged it back in, and all seems normal now.


I'll have to get a small zip tie and tighten it down.

Now with koeo, ebp is at 5psi. Map and baro are right at 14. Is the still a problem there?
GTPpower is online now   Reply With Quote
Old 05-08-2017, 10:29 AM   #21
WWMoMD
 
CTC DEEZUL's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 30,955
Casino cash: $128220000
9.34 per day
Mentioned: 381 Post(s)
Tagged: 0 Thread(s)
Default

KOEO means key on engine off.
CTC DEEZUL is online now   Reply With Quote
Old 05-08-2017, 01:00 PM   #22
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

Yeah I know that.

I'm thinking that there is a problem with the ebp sensor according to some dieseltechron videos. He is saying that ebp and map should be very close. Mine are not.

It also doesn't have as much power as it did when I first got it. On the extreme tune, it blows a decent amount of black smoke when I floor it.
GTPpower is online now   Reply With Quote
Old 05-25-2017, 11:45 AM   #23
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

Changed the coolant filter. There was about 6500 miles on it.





I dumped the old filter out. There was a lot of crap in it.



I'm not real sure what that is. It's all pretty dark in color.
GTPpower is online now   Reply With Quote
Old 05-25-2017, 11:56 AM   #24
WWMoMD
 
CTC DEEZUL's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 30,955
Casino cash: $128220000
9.34 per day
Mentioned: 381 Post(s)
Tagged: 0 Thread(s)
Default

Casting sand. Cut the filter open next. That's alot for having all that work done... Don't be surprised if your oil cooler restricts a tad with all they left in the system

After seeing that I'd go 2x or 3x the milege on next filter. After that once a year.
CTC DEEZUL is online now   Reply With Quote
Old 05-25-2017, 12:09 PM   #25
 
GTPpower's Avatar
 
Join Date: Jun 2012
Location: Nebraska
Posts: 1,340
Casino cash: $14840500
0.66 per day
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Default

Crazy how the oil cooler has been replaced twice on here, and there is still all that sand. I still have the filter...should I cut it open?

My deltas still look good. 8°is about the biggest difference i see.
GTPpower is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:42 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
no new posts