What did I break?

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
Car started running like shit one day, so I used my Bluetooth module and noticed my O2 sensor died, replaced the sensor. While I had the car running I noticed that I'm getting a lot of white smoke out of the oil breather (where my oil cap would be, if I wasn't running a breather. Seems to puff like a cylinder lost compression and it's getting to the crankcase. Don't seem to be losing any coolant or getting a mix of coolant oil.

Also think I have an alternator that can't keep up (when the high speed fans kick on the cars idle dips down and the voltage drops) or maybe a ground that is shitty?

Did I fry the rings? Seems like it's cylinder number 6 (per the misfire code that JUST popped up)
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
A bad sensor really f***** with fueling but aside from managing to run really rich and wash down the cylinder walls I could only think of one of your injectors possibly streaming and killing the ring seal that way.
A new O2 sensor with it reading proper stoichiometric I could imagine it would start better and faster.
The Rings you might have gotten worse but you may just be stuck with it at this point unless it is a clogged fuel injector that is not misting properly
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
A bad sensor really f***** with fueling but aside from managing to run really rich and wash down the cylinder walls I could only think of one of your injectors possibly streaming and killing the ring seal that way.
A new O2 sensor with it reading proper stoichiometric I could imagine it would start better and faster.
The Rings you might have gotten worse but you may just be stuck with it at this point unless it is a clogged fuel injector that is not misting properly


Hmm anything to check or try? Or just run it and see what happens?
 

P40E

Well-known member
Joined
Nov 4, 2012
Messages
7,421
Reaction score
54
What did the sensor look like when you pulled it ? Are you getting smoke out the radiator ?

Blown rings will cause black smoke out exhaust. And smoke in the crankcase , but it's usually not white. Grey ish maybe .

If you think its one bad piston making the car run like shit , pull a spark plug wire till you find the hole that doesn't change idle . Then look at the spark plug . Or do a compression test on all .
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
You could do a cold and hot engine, cylinder leak down test and check to make sure it's within 5% of the rest


If I just check hot since I don't have the tools, I'd be going to a shop my buddy works at, what am I looking for? I'm sure he would know. Or do I NEED to check both hot and cold?
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
What did the sensor look like when you pulled it ? Are you getting smoke out the radiator ?

Blown rings will cause black smoke out exhaust. And smoke in the crankcase , but it's usually not white. Grey ish maybe .

If you think its one bad piston making the car run like shit , pull a spark plug wire till you find the hole that doesn't change idle . Then look at the spark plug . Or do a compression test on all .


Sensor was whiteish. This car seems to eat these things for some reason. I only use denso too. I don't know about smoke out the radiator. But no smoke out the over flow.

I'll try to take a video later. Smoke seems white to me.

The car runs pretty fine so long as my idle doesn't dip down when I go to stop at a red light, then the alternator only charges about 12 volts and it idles like shit (and rich) until I bring the idle up a couple hundred rpm. I ordered an alternator, hope that's my problem that it just can't put out at idle. Was a autozone alternator from 3 years ago.

Is it possible I have a head gasket that's messed up but not leaking coolant? I am running about 14/15 psi on a stock compression stock gasket L36.
 

98GrandPrixIraqVet

Well-known member
Joined
Jan 26, 2015
Messages
14,233
Reaction score
172
Location
Nowheresville North Dakota
The car runs pretty fine so long as my idle doesn't dip down when I go to stop at a red light, then the alternator only charges about 12 volts and it idles like shit (and rich) until I bring the idle up a couple hundred rpm. I ordered an alternator, hope that's my problem that it just can't put out at idle. Was a autozone alternator from 3 years ago.
that does sound like an alt. runs fine besides low rpm or idle makes me think a damn MAF dont know why but my s1x e85 car used to eat those.
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
I used one of those "combustion leak testers" that uses the blue fluid. Definitely turned greenish/yellow. Starting to lean more towards some sort of head/head gasket issue. Right?
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
Does your cooling system build pressure before the engines even warmed up?


How would I know? The engine warms up pretty quickly. In the overflow I see an air bubble every few seconds when it's up to temp and running. But the overflow has a vent..

If I wasn't leaving a dusting of smoke randomly when driving I wouldn't much care since the car runs decently.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
a leakdown test would have probably given you bubbles through the radiator.

use a mirror and light to see any area's of the HG that may have blown out below the exhaust header to head flanges. if you cant see a pushed out gasket then a leakdown would at least tell you which bank to yank the head off of
 

10sec

I haz dat teddy bear smile.
Donating Member
Joined
Jul 26, 2008
Messages
23,527
Reaction score
256
If you're not mixing fluids, just leave it alone and keep driving it.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
uh, don't give shitty advice.
at the least do a cyl leakdown test, testers at HF are fairly cheap but you can also put an air hose fitting onto a comp tester hose to inject air and find the dead hole.
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
Which headgasket(s) or engine gasket set (I assume I need the lower and plenum gaskets) and which head bolts? GM stuff only?

Is 15psi too much on stock head-gaskets on a L36? Or might there have been another reason?
 

GTPpower

Well-known member
Joined
Jun 5, 2012
Messages
2,309
Reaction score
98
Location
Nebraska
Gm, Victor reinz, or felpro all work well. You will either need new bolts or arp studs.

The l36 should be able to handle those pressures without any issues. You probably had some detonation that pushed the gasket out.
 

10sec

I haz dat teddy bear smile.
Donating Member
Joined
Jul 26, 2008
Messages
23,527
Reaction score
256
Fuck tests, keep driving it until something actually breaks.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
What so he can overheat the s*** out of it lunch the motor and possibly crack the radiator from overpressure... brilliant
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,148
Reaction score
23
Location
Chicago (Southside)
Definitely don't wanna do that. Motor seems strong considering.

James you wanna tear into it? lol I don't really wanna pay a shop since it'll be a ridiculous amount especially since they might say my shit isn't stock so they really don't wanna do it.

Idk if a guy I used to work with would be interested, now that it's getting colder out and I'm not sure his garage is heated.
 

10sec

I haz dat teddy bear smile.
Donating Member
Joined
Jul 26, 2008
Messages
23,527
Reaction score
256
He has like 1 problem but the car is fine, why the FUCK should he care? Drive it, fuck looking at it.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
Definitely don't wanna do that. Motor seems strong considering.

James you wanna tear into it? lol I don't really wanna pay a shop since it'll be a ridiculous amount especially since they might say my shit isn't stock so they really don't wanna do it.

Idk if a guy I used to work with would be interested, now that it's getting colder out and I'm not sure his garage is heated.
best I could suggest is my buddy JR up at Harry's on rand, he's always looking for racecar $ for the nova.

if you narrow it down to a bank, you can just do the one and yank the other exh manifold to Rtq the studs. or are you oe bolts?

Maybe you can zip tie it, 10sec style.
I chuckled

He has like 1 problem but the car is fine, why the FUCK should he care? Drive it, fuck looking at it.
what in the hell is wrong with you?

he's pushing combustion gasses, he can save himself a lot of $ and headache.

its like I hardly know you anymore
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom