Thrown Cam Follower Symptoms?

ShelbyGuy

Turgid Member
Joined
Mar 26, 2004
Messages
5,231
Reaction score
0
Car idles a bit rough. Its always had a tiny miss, but now its a definite, intermittent miss. Plugs look fine, though. a:f at idle is around 14.2:1, but cruising idle is normal 14.7:1.

Only thing I can think of is maybe it spit a cam follower out.
 

rdsnake

formerly RD SNAKE
Joined
Mar 5, 2006
Messages
5,571
Reaction score
26
Car idles a bit rough. Its always had a tiny miss, but now its a definite, intermittent miss. Plugs look fine, though. a:f at idle is around 14.2:1, but cruising idle is normal 14.7:1.

Only thing I can think of is maybe it spit a cam follower out.
Is it making any noise from the front cover? When I rebuilt my engine, the follower's looked new, so I reused them, however I did replace the chain's and tensinor's. This is all at about 20K on the clock. I no you have a lot more miles then that.

Kevin
 

ShelbyGuy

Turgid Member
Joined
Mar 26, 2004
Messages
5,231
Reaction score
0
I've replaced the four coil packs on the driver's side (all I could afford at the time) .

MIL is not lit so I didn't bother to scan for codes. I realize it may have stored codes.

Car idles just fine when the a/c is on.
 

rdsnake

formerly RD SNAKE
Joined
Mar 5, 2006
Messages
5,571
Reaction score
26
Have you ever thought about having the injector's cleaned and flow. A new set of injectors makes a world of difference.

Kevin
 

Dana

Bluesmobile
Joined
Mar 2, 2004
Messages
2,619
Reaction score
0
Have you checked for vacuum leak?
There are a lot of potential trouble spots on these cars.
One that has cropped up is the PCV hose on the driver's side valve cover.

Dan
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom