Ported blower install.... need help

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
Hey guys, just put a stage 4 ported blower on my car, easy in stall no problems what so ever.
when i started the car however it made this un godly loud squeel (not the s/c whine) that started, then went away then started up again. I did not let the car run for to long in fear of hurting anything. Any ideas or directions of what i should look at/for would be of great help to me!

This was a used blower i bought off this site from a member, said it worked great.
 

greasy

I Haz New Teknologee
Donating Member
Joined
Jun 25, 2007
Messages
28,809
Reaction score
258
Location
The Litter Box
Maybe something belt or pulley related, are you running the same pulley sizes and belt size?
 

Mook

El Presidente
Admin
Joined
May 23, 2007
Messages
163,870
Reaction score
1,818
Location
Elgin
First guess would be belt.
 

Eagle

Nemo me impune lacessit
Super Moderator
Joined
Mar 1, 2008
Messages
62,566
Reaction score
58
Location
Woodsticks, IL
Other ideas would be vac leaks that are causing whistling, bearings in the blower that might be dry since the last time it ran, or most likely, the belt(s).
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
k, its a 2.93 billet flow with all other pulleys/tensioner being stock. Went with a different blet. Im going to try it again and have my dad watch the belt
 

Mook

El Presidente
Admin
Joined
May 23, 2007
Messages
163,870
Reaction score
1,818
Location
Elgin
Check the tension on the belt. On my car, if it doesn't sit right in the middle, screams like crazy. Also, I suggest a gatorback belt.
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
belt/ pulley spun fine. It almost sounds like a bearing or something.... but i have not idea
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
think he said 5k, belt is sitting right in the middle of ALL tensioners/pulleys
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
still why would going from a blower with a 2.76 to a ported blower with a 2.93 running the same style of belt cause this to happen?
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
stock lower. and the ported blower already had that pulley on it. I was just trying to get the thing running
 

greasy

I Haz New Teknologee
Donating Member
Joined
Jun 25, 2007
Messages
28,809
Reaction score
258
Location
The Litter Box
think he said 5k, belt is sitting right in the middle of ALL tensioners/pulleys
still why would going from a blower with a 2.76 to a ported blower with a 2.93 running the same style of belt cause this to happen?
There is an indicator on the tensioner that shows belt tightness. There are 2 raised marks, one is raised more than the other. If the arrow is pointing right in the middle where the raised marks meet you are golden. If not you need to adjust belt sizes.

Did you change belts at all when you went to the new blower setup? If not your belt is probably too tight because you stepped up a pulley size, but never got a bigger belt. I would suggest stepping up one belt size if you never changed the belts. Too much tension or too little will cause the car to scream like a banshee.

A squealing belt will look just fine. Are the gatorback belts the green ones? That's what everyone I know runs.
The Gatorbacks are black, but have provisions on the belt that travel diagonally to the ribs that allow the belt to be more quiet than say a Gates Micro-V. Gates Micro-V belts operate quietly if you have exact pulley alignment.
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
i did go up a belt size from what i was running
 

greasy

I Haz New Teknologee
Donating Member
Joined
Jun 25, 2007
Messages
28,809
Reaction score
258
Location
The Litter Box
I still looks like the belt tension is too tight. Where do you live?
 

greasy

I Haz New Teknologee
Donating Member
Joined
Jun 25, 2007
Messages
28,809
Reaction score
258
Location
The Litter Box
If I did not have to head out in a little bit I would stop by. What belt size are you running right now and what were you running before?
 

greasy

I Haz New Teknologee
Donating Member
Joined
Jun 25, 2007
Messages
28,809
Reaction score
258
Location
The Litter Box
I am almost positive the belt being too tight is causing the loud whine.
 

kweb288

Well-known member
Joined
Mar 18, 2009
Messages
686
Reaction score
0
its a 74" and 3/8" belt

its cool i gotta go to bed soon anyways cause im waking up at 230 am for work

What about bearings???? any chance it could be that? i dont really know how to read that marker thats why i posted the pic
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom