• Hi Guest, welcome to TCG 2.0. Please refer to the FAQ in User Support before you do anything else. It will make the transition MUCH easier.

    IF YOU ARE SEEING AN "OOPS" ERROR PAGE, IT IS LIKELY BECAUSE YOUR BROWSER HAS NOT UPDATED YOUR CACHE. YOU CAN EITHER CLICK FORUMS AT THE TOP LEFT OR VISIT THECHICAGOGARAGE.COM AND BOOKMARK THAT. - Love, Mook

Oil everywhere

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
I was driving my car today after the header install (about two weeks ago) just got it out of storage, and smelt something burning. i just thought it was the headers buring off my finger prints. I get home and pop the hood to find oil everywhere. It was leaking in the front of the motor. so i figured it was the valve cover gasket so i replaced it. Everything was good no leaks. I took it for a ride about 2 miles and come home same frikin thing, oil dripping on my front header valve cover is soaked and s/c has oil spashed on it. The fas are bone dry so it is not hitting the fan and spraying all over. If anyone has any clue what it could be please help me out! Thanks in advance.

John
 

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
DING DING DING we got a winner sortof i checked the dip stick, not the tube, and thats where it is "spraying" out of. But mine was bad so i just tried my buddys he has a gtp too and cleaned the oil off everything took it for a spin and IT POPPED OUT AGIAN!!! His oring on the dip stick is good and everything. Any ideas to why it is coming out. I think it might be only at 3/4 throttle or higher. Thanks agian
 

thebullfrog

Well-known member
Joined
Sep 12, 2008
Messages
712
Reaction score
0
Location
Algonquin
PCV is bad. Might try cleaning it, or you may just have to replace it. ^^beat me to it.^^
 

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
i went to look and my friend reminded me that my intercooler has no hole for the pcv. I just rembered i took the breather off yesterday to clean it and i threw the cap back on thus probley making to much pressure and popping it off??? i hope. Any thoughts?

THanks
 

Toasty

Well-known member
Joined
Nov 4, 2007
Messages
1,207
Reaction score
0
Location
Bolingbrook, IL
i went to look and my friend reminded me that my intercooler has no hole for the pcv. I just rembered i took the breather off yesterday to clean it and i threw the cap back on thus probley making to much pressure and popping it off??? i hope. Any thoughts?

THanks
[/b]

yeah that would probably do it
 

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
Thanks for all the help everyone. im too tired to put the breather on now and take it out agian. i installed a shift kit on it today and havent even got to try it out. hopefully tomarrow. Ill put the breather on tomarrow and let you guys know how it went. Thanks!!

john
 

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
Just got done cleaning it all up. And it was the oil cap being on the valve cover. I threw the breather back on and everything is good. Agian thanks to everyone that help me figure it all out.
 

phat_ridegt

Well-known member
TCG Sponsor
Joined
Sep 16, 2007
Messages
3,351
Reaction score
1
Location
Ottawa
i see you have a wbs sII i/c...

how old is it? you should have functional pcv
 

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
i installed it in september of 06. I belive it is the current one they are selling now.
 

phat_ridegt

Well-known member
TCG Sponsor
Joined
Sep 16, 2007
Messages
3,351
Reaction score
1
Location
Ottawa
did you install their LIM? you need to have a hole drilled in the LIM for the pcv to be functional
 

john99gtp

Well-known member
Joined
Jul 20, 2007
Messages
280
Reaction score
0
Location
lockport
no i have the stock LIM :( . i need to replace the LIM gasket in the near future. then ill pick up a
machined intake.


did you install their LIM? you need to have a hole drilled in the LIM for the pcv to be functional
[/b]
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom