• Hi Guest, welcome to TCG 2.0. Please refer to the FAQ in User Support before you do anything else. It will make the transition MUCH easier.

    IF YOU ARE SEEING AN "OOPS" ERROR PAGE, IT IS LIKELY BECAUSE YOUR BROWSER HAS NOT UPDATED YOUR CACHE. YOU CAN EITHER CLICK FORUMS AT THE TOP LEFT OR VISIT THECHICAGOGARAGE.COM AND BOOKMARK THAT. - Love, Mook

Need Help/Insight - 3800 stalling/running rough/acting like s00ls (weird)

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
My car has been running rough every now and then ever since Wed night.

It was randomly stalling out at idle, stoplights, etc...

I replaced the spark plugs with ACDelco 41-101's on Saturday at TheAutoGuys's House.

While at work last night, it really didn't stall out as much as it did, but it did throw a SES light that went away.

I was attributing it to bad gas, but I am not so sure now because of what it did later last night when I tried to move it.

It acted like it was getting no fuel for about 5 minutes... I finally turned the key off and on about five times to let the fuel pump prime and then it started right up.

Therefore I am thinking Fuel Pump or fuel filter? are my assumptions along the right lines?
 

AlmightyBirdman

*shrug*
Joined
Mar 18, 2008
Messages
6,714
Reaction score
0
Location
Detroit Rock City
My car did shit like that when my battery was dying. Get it tested, or check the connections to your battery. I would get it scanned to see if the code that you threw stored though, it could have something to do with it.
 

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
I'd like to rule out battery... it has a really strong charge.

Concerning codes, I'll take it over to Vatozone... less than 2 blocks away...
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
wed was the last snow, so chances are you got salty water on the wires and they started leaking voltage and are now shot, though it could be other things...

next time it's dark out grab a bottle of soapy water and spray all the wires down...if you see a lightning show...replace the wires...if your a badass like me you can just ground one hand and run your other hands down the length of each wire...bettter than a cup o joe lol
 

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
These wires still look the same as they did when I put them on in fall of '08...

There might be a dumb issue on my part. I may have gapped the new plugs too open... to 0.65. Autozone lists the 41-101s as needing gap of 0.60.

Either way, the car is throwing "P0300 - Multiple Misfires" and the exhaust smells like sulfur after it dies and I have to fight with it to get it back started. I may not have use of the heated garage where I changed the plugs, so pulling them out in freezing temperatures will have to do.
 

02BlueGT

No Fucks Have Been Given
Joined
Feb 21, 2008
Messages
9,918
Reaction score
3
Location
Now apearing in Hanover Park
My car did this when my MAF failed, I had to two foot it to keep the engine running, try with the Maf unpluged (didn't work as a test for me, but others have had luck), or if you have someone nearby with another 3800, borrow the known good MAF and see if it fixes your issue.....

Oh, and check the FPR for a leaking diaphragm
 

PANDA

Well-known member
Joined
May 24, 2007
Messages
34,200
Reaction score
25
Location
FRG
SHOULD HAVE DONE A VE TUNE MOTHERFUCKER
 

Eagle

Nemo me impune lacessit
Super Moderator
Joined
Mar 1, 2008
Messages
62,545
Reaction score
19
Location
Woodsticks, IL
+1 to wires, or possible MAF. Unplug the MAF and see if it changes. If not, damn near sure its the wires at that point.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
the icm's are pretty bulletproof, though salt/water can get into the electircal connector unplug it and see if it's moist (7mm)
 

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
I do still have an aftermarket warranty on this car, and it's looking to become a job where I will have the stealership work on it because I am pretty sure that MAF, ICM, and such are covered... I'll pay up to my deductible of $250...
 

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
i just saw they are at .65? close em up, btw wires commonly break internally during twisting/bending of a plug change,
Started this issue before changing the plugs... I had some old Autolite 104's in it previously...

DD scanned it last fall at Luke's and it was sometimes misfiring on 1 and 4...
 

TommyGloves

Well-known member
Joined
Aug 23, 2007
Messages
5,647
Reaction score
11
Location
CHICAGO
I have a low mileage 99+ MAF for sale if ya need it. I'll sell it to ya cheap. :)
 

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
I'm thinking problem lies elsewhere now?

This issue doesn't crop up all the time, it's intermittent... could a Throttle Position Sensor that is going bad cause idle issues and Toyota Syndrome (constant acceleration with foot off of gas pedal)

The reason I ask is that today the car seemed even more possessed... idled up to 3000 RPM after I disconnected and reconnected the TPS... disconnecting and reconnecting the MAF did nothing... I did that prior to disconnecting the TPS.
 

RebelTJ

Coyote Bus Lines
Joined
Jul 16, 2008
Messages
7,811
Reaction score
7
Location
Rockford
Replaced Fuel Filter Yesterday... I coughed up $50 to have Tires Plus in Cherry Valley do it...

It seems to have fixed the intermittent stalling and running rough... It's like nothing was wrong except for the fact that when I am on I90, the SES light flashes... no misfiring... it's weird... I'm going to get with TheAutoGuy to use his garage to pull the plugs and regap them to .060 to see if it is that.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom