My converter quit locking up. Is it toast?

Shibby50

Well-known member
Joined
Mar 30, 2008
Messages
4,988
Reaction score
20
Location
Braidwood, IL
A few weeks ago I was cruising home with a buddy. Had the cruise control on and all of a sudden it unlocked and slowly rose up to about 3500rpm.
Didn't throw any codes.
Initially I thought overdrive went out because it never really felt like it was going through all the gears. So I started trouble shooting. Changed out the maf tps sensor and made sure the fluid was dead on filled.
Also the fluid looks like brand new no coloring at all.
Finally got to take it to a local trans shop and took the head guy for a ride and be said the converter is basically fucked because its not locking up.
Is there any reason for it to take a shit on me already or am I missing something maybe electronically that would tell it to stop locking up?

It's a yank SS4000 that's just over a year old. Never sprayed the car with this converter either. It's had abou 15 passes on it.
Someone give me good new because these converters are killing my budget :run:
 

Shibby50

Well-known member
Joined
Mar 30, 2008
Messages
4,988
Reaction score
20
Location
Braidwood, IL
Gonna do that after work. Gotta see if I can find the receipt. I think they have a warranty do they not?
I just found out it was the converter on the way to work so I haven't had time to call :(
 

Eagle

Nemo me impune lacessit
Super Moderator
Joined
Mar 1, 2008
Messages
62,566
Reaction score
59
Location
Woodsticks, IL
Not sure on the warranty... but I'm sure they'll be willing to give you much more sound advice than TCG will! :D
 

Eagle

Nemo me impune lacessit
Super Moderator
Joined
Mar 1, 2008
Messages
62,566
Reaction score
59
Location
Woodsticks, IL
I'd guess its more of a trans issue than a converter issue, but that's just me.
 

willizm

Ho fuckin Ho!
Joined
May 13, 2009
Messages
10,545
Reaction score
103
Location
Saint John, IN
When you drive it with half throttle does it go through 1st and 2nd fine and then when it gets into 3rd or OD does the rpm just bounce up? Might be 3-4 clutches or a bad solenoid too.
 

Shibby50

Well-known member
Joined
Mar 30, 2008
Messages
4,988
Reaction score
20
Location
Braidwood, IL
Negative. It shifts into 3rd just fine then feels like it never shifts to od but it does. If I move the shifter from 3 to od to 3 it jumps about 200rpm then goes back. Converter def isn't locking.
 

Pewter-Camaro

Well-known member
Joined
May 28, 2011
Messages
2,075
Reaction score
32
Location
Schaumburg
Also find someone that has software to do data logs and start looking at what is going on before replacing hard parts. You never know it could be something like a temp sensor going whacky and the ECM not commanding the TCC lock.
 

Shibby50

Well-known member
Joined
Mar 30, 2008
Messages
4,988
Reaction score
20
Location
Braidwood, IL
Well just logged it. Shifting normal apparently and It's showing the computer telling it to lock and shows 90% lock pressure so it's the damn converter. Calling yank tomorrow fuu
Just glad it's not the trans
 

CrunkMaro

DurkaDurkaTerrorist
Joined
Jun 17, 2010
Messages
2,700
Reaction score
1
what did you use to scan it? if you used efilive...it should tell you why its not locking even if its commanding a lock...there has to be quite a few requirements that need to be met for it to lock.
i had a similar issue and multiple scans with various PIDS selected showed a faulty brake switch.

i'm sure hptuners can be set up to do the same.
 

Gav'sPurpleZ

If you fail to plan, you're planning to fail
Donating Member
Joined
Mar 3, 2008
Messages
32,391
Reaction score
229
Location
Pingree Grove IL
could be the OD band.

thats what broke twice on my friends 00 SS.... twice.
he was running a 3600 vigilante
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom