• Hi Guest, welcome to TCG 2.0. Please refer to the FAQ in User Support before you do anything else. It will make the transition MUCH easier.

    IF YOU ARE SEEING AN "OOPS" ERROR PAGE, IT IS LIKELY BECAUSE YOUR BROWSER HAS NOT UPDATED YOUR CACHE. YOU CAN EITHER CLICK FORUMS AT THE TOP LEFT OR VISIT THECHICAGOGARAGE.COM AND BOOKMARK THAT. - Love, Mook

Knock sensor turn on temp

thebullfrog

Well-known member
Joined
Sep 12, 2008
Messages
712
Reaction score
0
Location
Algonquin
What's the turn on temp for the knock sensors in a 2000 GTP? I thought it was really low, and '97- '99 was 165. I'm asking because I put in a drilled 180 stat today. The good part is the lower temps seem to have dropped at least 1/2 degree of knock on average so far. The problem is that it's registering zero knock until the temp hits 160. I drove all the way from C-ville to C.L. and my temps on the highway hovered around 145-150. When I hit it I got no knock. After sitting at a light my temp went to about 161. My stupid amounts of knock were back in all their glory. Wasn't a problem in the afternoon, but at 1 AM when it's colder is another story. I could have sworn that's why 2000 and up had the sensors kick on at around 100, not 160. I'm not too fond of timing not being pulled to compensate for the knock I know I have, but that can be dealt with via a diff. stat or being careful when it's cold out for now. Mostly I'm just perplexed as to why my 2000's sensors are behaving like the older models. PCM was replaced at some point perhaps?
 

thebullfrog

Well-known member
Joined
Sep 12, 2008
Messages
712
Reaction score
0
Location
Algonquin
AH, gotcha. Thank's. I could have sworn 99 was the last year. Cool, I'll just be careful whenever it's below 160 then. Damn it is fast with full timing though. I REALLY need to get that fuel filter and DP on soon. It is nice however that once it is warmed up, my knock does seem to be lessened somewhat so far. I haven't had the chance to do any real logging yet, but things are looking up.
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,119
Reaction score
4
Location
Chicago (Southside)
AH, gotcha. Thank's. I could have sworn 99 was the last year. Cool, I'll just be careful whenever it's below 160 then. Damn it is fast with full timing though. I REALLY need to get that fuel filter and DP on soon. It is nice however that once it is warmed up, my knock does seem to be lessened somewhat so far. I haven't had the chance to do any real logging yet, but things are looking up.
[/b]
I believe it was JUST 99's and 00's that did this.. Did you ever find the cause of that one problem?
 

thebullfrog

Well-known member
Joined
Sep 12, 2008
Messages
712
Reaction score
0
Location
Algonquin
Which prob. The vibration? Not yet. It's goin in Mon. to be checked out. Since I rounded the Hell out of the Fuel Filter I'm having my mech fix that, and I'm having him do my brakes since it's there anyway. He's going to look and see if there's anything obvious causing the vibration. That'll most likely get done on another week or 2. I may have him bolt up my downpipe at that time too, just to get it done.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom