Jeep Dead. Help!

The Italian

But not Italian
Donating Member
Joined
Jan 31, 2008
Messages
7,515
Reaction score
95
Location
Gilbert, AZ
So my Jeep died today. I think its my starter but am not sure. Basically, when I turn the key, all the lights and accessories come on but the motor doesn't turn. No sounds from it or anything. Just dead.

Is it my starter or could it be something else? Thanks!
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
so imma guess this is a 72 jeep commando with a 304 amc v8 and a 3 spd manual...

just push start it and pop the clutch pussy
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
oh yer fucked if its a jeep newer than 99

did you try the neutral position of the shifter?

id find the starter relay in the underhood box, see if it clicks when cranking, if not, pull it and pop off the cover and then manually close it and see if it cranks (or use a paperclip to the proper secondary side pins) and youll be able to drive it at least

its possible its a starter but iirc thats a neutral/park switch to the pcm and the pcm enables the starter relay and it powers the starter solenoid.

more than a few times ive found older starters with the exposed motor lead (fromt he solenoid) corroding and eventually burning completly through, but youd hear the chunk of the bendix if that was the case.
 

Chester Copperpot

TCGs Far Right Leader
Donating Member
Joined
May 7, 2010
Messages
29,529
Reaction score
336
Location
Shithole, IL
Starter. Happened to me with my 99 Cherokee. Everything would turn on but wouldn't crank. Changed the starter, fired right up.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
yeah well the older jeeps used the nippondenso starter so you could just slap new brushes in the solenoid and your back driving for 10$

now its all bosch and you have to buy a brand new fucker

this world is so fucked with everything being non servicable
 

The Italian

But not Italian
Donating Member
Joined
Jan 31, 2008
Messages
7,515
Reaction score
95
Location
Gilbert, AZ
Yea, tried the shifting into neutral thing and got nothing.

Changing out the starter tonight.

Thanks guys... I appreciate the help!
 

87 IROC LT1

Active member
Joined
Sep 15, 2013
Messages
32
Reaction score
0
Location
Darien IL
My 05 WK 4.7 did the same thing, its the connectors to the starter, they used cheap alloy and they corroded. I took them off, wire brushed them clean and used some electrical grease when i put them back on, thing still cranked all day when i traded it in at 160k.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom