Help

Topless Cobra

New member
Joined
Mar 28, 2007
Messages
1
Reaction score
0
I have an 03 cobra I was currently running a 3.1 upper sc pulley with a diablo sport chip, and bassani exhaust. I changed the 3.1 and put a 2.81 pulley on the stock eaton and after driving it around for awhile with some hard acceleration it was fine. Then out of knowhere under hard acceleration it has started stumbling and falling on its face. I put the 3.1 back on and now it doesn't do it anymore. Also I have been noticing before that it had an extended crank like maybe the fuel pump is geting weak. It only has 33k on it. I was under the understanding that all I needed was the custom chip when making pulley upgrades like the diablosport chip I have. So does this sound like a fuel problem to you guys because the chip I have is tuned for the pulleys. How good are the stock pumps what are their hp range. If it is a fuel problem what kind of pump should I get. Any help is appreciated I'm open for all suggestions of what I need to do. THANKS
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,221
Reaction score
15
Location
SFO
Your fuel system should support that. Your maf might be close to pegged (its possible).

I'll wait for some other folks to chime in.
 

rdsnake

formerly RD SNAKE
Joined
Mar 5, 2006
Messages
5,608
Reaction score
52
First off I would check the tune. If your car is tuned for x amount of boost, then swtich the x amount of boost, the fuel cruve is going to be off.

Sec. I would pull the plugs and check them out.

Third. if your getting hesatation between shifts, then you might need to remove your PPRV in the fuel tank

Kevin
 

Dana

Bluesmobile
Joined
Mar 2, 2004
Messages
2,619
Reaction score
0
Close the gap down on the plugs.
How long has it been since the fuel filter has been changed?

Dana
 

Dragon03

Super hated on
Joined
Mar 28, 2007
Messages
27,350
Reaction score
0
VenomInside said:
Your fuel system should support that. Your maf might be close to pegged (its possible).

I'll wait for some other folks to chime in.
I agree I ran 15lbs of boost on a steigemeir port with a stock fuel pump and stock injectors and had no issues. Do you have a rough idea of where it was falling on its face low, middle, top end? I am also in agreement with the possiblity that your MAF could be maxed out. Do you still have the stock plugs? Before when I had the stock plugs I was blowing the spark out a higher rpms...changed to NGK plugs fixed that.
 

Flatliner

I'm kind of a big deal...
Joined
Mar 3, 2004
Messages
35,000
Reaction score
0
The tune should adjust, usually amount of boost doesn't matter the fuel tables should make the adjustment. Now what that adj is you need to datalog to make sure. I would follow Dana's advice first and then datalog
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom