Help!! Rear main seal question

stupidgenius

Active member
Joined
Feb 9, 2007
Messages
44
Reaction score
0
while i had my trans down for replacing my clutch i thought i might as well replace the rear main seal. i took the old seal out using a screw to grab it then pull it out.

the new seal that autozone gave me does not match what i removed from the block... i am wondering if the old seal broke in half. i'd go ahead and try to remove the rest of what appears to be the seal around the crank, but i dont want to screw into something that's not the rear main seal.

here is a picture of what my crank looks like right now. is part of the old seal still stuck in it, or did i get the wrong seal from autozone?

crankshaft area
new seal on left, old on right
 

CREJoe

Chassis Builder
Joined
Jun 15, 2007
Messages
96
Reaction score
0
It looks like you didn't get all of the old one out.
 

Bullitt-1469-

Well-known member
Joined
Jun 11, 2005
Messages
406
Reaction score
0
The old one is still in there take the rear main cover off and replace it, its held on by two bolts under the oil pan and six on the block...
 

Frodo

Well-known member
Joined
Jun 2, 2009
Messages
6,564
Reaction score
0
You definately did not get all of the old seal out, if you have a pick of some sort you could try using that get the remainding part out, just be careful. but the best option is using a seal puller
 
OP
stupidgenius

stupidgenius

Active member
Joined
Feb 9, 2007
Messages
44
Reaction score
0
The old one is still in there take the rear main cover off and replace it, its held on by two bolts under the oil pan and six on the block...
yep that was it. i figured it out after checking out a chilton book, but you were exactly right. thanks!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom