• Hi Guest, welcome to TCG 2.0. Please refer to the FAQ in User Support before you do anything else. It will make the transition MUCH easier.

    IF YOU ARE SEEING AN "OOPS" ERROR PAGE, IT IS LIKELY BECAUSE YOUR BROWSER HAS NOT UPDATED YOUR CACHE. YOU CAN EITHER CLICK FORUMS AT THE TOP LEFT OR VISIT THECHICAGOGARAGE.COM AND BOOKMARK THAT. - Love, Mook

headlight problems

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,119
Reaction score
4
Location
Chicago (Southside)
I had 9005/9006 Silverstar headlight bulbs in my Regal, but they began to start burning out in the last two months. The highs even burnt out around the same time, and they are rarely used compared to the lows. I put them in in the summer time so theyve only been in about 6 months. I had been running them with a headlight harness from suvlights.com, which seemed to have some issues (may have been ground issues) where if I turned on my fogs the bright would come on. This would not happen all the time, but sometimes. I'm wondering what caused this problem?

-Headlight harness too strong for bulbs, or poor grounding even though the bulbs lit up fine and looked great?
-Headlights have condensation problems, but the bulbs didnt burn out when there was condensation in there, and all the bulbs filaments just broke.

I will be getting another headlight harness and using this current one for my new foglights. I may have the wrong harness as I need one that has low on with highs.

Also my turn signal bulbs, well the socket for the one on the driver sad keeps melting the bulbs plug in end and the bulbs eventually end up not working. This happens about once a month.

-Nick
 

The Broken Regal

BITE BITE, SIP SIP
Joined
Jun 26, 2007
Messages
14,726
Reaction score
14
Location
Wheaton
ive got the same ones.. but i have not had any problems... we both have regals ....... wierd, sorry i cant help
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,119
Reaction score
4
Location
Chicago (Southside)
Do you have a upgraded headlight harness?? Im guessing its probably my stupid headlights needing to be resealed. Well I will get another harness aswell as reseal them, and rule out both possibilties.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom