For those of you on stock bottom ends w/ forced induction..

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
I am making this thread to document my process of pulling apart and trying to figure out what went wrong.

Lets start off with some info.

1996 mystic cobra.

Mods:

Vortech (S-Trim) V1 Supercharger
Ford 42/lb injectors
SCT MAF
Flowmaster cat-back
Bassani X
SVO shorty headers
31 spline axles
Short Throw Shifter,
subframe connectors
Eibach Springs
Adjustable struts and shocks
BBK caster camber
BBK throttle body
MSD ignition
Ford 3.55 Gear
Autometer fuel and boost pillar guages
Raptor shift light
Mickey Thompson E.T. Streets

Car Made 455rwhp/395rwtq @ 10psi

Gas= 93 Octane via mobile gas

Plugs =

This is what happened.


OIL FIRST STARTING TO POUR OUT









Here are 1 vid of it right after we noticed something was wrong..




Here is what it looked like when i pulled the plugs..








Update...

Didn't get a chance to pull the heads off or the intake for that matter since the throttle body and inlet tubing were being a bitch. Plus my buddy adam decided that it was ok to accidently drop the throttle linkage down somewhere by the headers. :mad:

Here are some updated pics.

Elbow



Inlet



Throttle Body



Inlet to supercharger



Bottom of blower from underneath the car



Drained oil



Air Filter



UPDATE

Well, Got more done with the help of Erik (aka MGT2002) and my girlfriend who helped out as well. Turns out she is mechanically inclined ;)

Anyway..

Got the spark plug wires etc off, blower, brackets, coolant res, intake manifold etc etc etc..

Btw, THANKS ERIK for coming out again :headbang:

































Here are some more pics from the tear down.

















 

ChromeCobra

Well-known member
Joined
Nov 19, 2005
Messages
16,001
Reaction score
1
What kind of plugs are those? Also, what kind of gas were you using when it blew?
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
ChromeCobra said:
What kind of plugs are those? Also, what kind of gas were you using when it blew?
I was using 93 octane from mobile

The plugs i will have to get back to you on. I'll see what they were gapped to.
 

Shane97Cobra

Well-known member
Joined
Apr 27, 2005
Messages
963
Reaction score
0
I've got $100 on a broken ring land. Like I mentioned on the phone, your at the HP level when the block can give up the ghost. I'm thinking ring lands due to the fact that you are getting so much oil blow it is getting sucked into the bi-pass and recirculated into the power pipe...then running down and out the filter.

Be happy a ring land broke and not a rod, atleast your block and crank 'should' still be good. Atleast there isn't a whole in the side of it.


What hole did those really oily plugs come out of? 7 or 8?

Do a compression test if you have the tools, it will tell you if the ring lands went.
 

95trippleblackconv

Well-known member
Joined
Apr 27, 2006
Messages
532
Reaction score
0
Shane97Cobra said:
I've got $100 on a broken ring land. Like I mentioned on the phone, your at the HP level when the block can give up the ghost. I'm thinking ring lands due to the fact that you are getting so much oil blow it is getting sucked into the bi-pass and recirculated into the power pipe...then running down and out the filter.

Be happy a ring land broke and not a rod, atleast your block and crank 'should' still be good. Atleast there isn't a whole in the side of it.


What hole did those really oily plugs come out of? 7 or 8?

Do a compression test if you have the tools, it will tell you if the ring lands went.
+1
 
V

venmousracer

Guest
Do a compression test and Leak down test, that will tell you what cylinders are bad... Especially a leak down test. Time for you to call RGR, Rich Grohl Racing, to have you build a bottome end for your motor...Eddie
 

slow4.6

Well-known member
Joined
Mar 20, 2006
Messages
1,112
Reaction score
1
venmousracer said:
Do a compression test and Leak down test, that will tell you what cylinders are bad... Especially a leak down test.

mabe you have a blown head gasket :confused:
 

Bob_Kurgan

Flyin_Hawaiin
Joined
Feb 16, 2005
Messages
3,013
Reaction score
0
Shane97Cobra said:
I've got $100 on a broken ring land. Like I mentioned on the phone, your at the HP level when the block can give up the ghost. I'm thinking ring lands due to the fact that you are getting so much oil blow it is getting sucked into the bi-pass and recirculated into the power pipe...then running down and out the filter.

Be happy a ring land broke and not a rod, atleast your block and crank 'should' still be good. Atleast there isn't a whole in the side of it.


What hole did those really oily plugs come out of? 7 or 8?

Do a compression test if you have the tools, it will tell you if the ring lands went.
i would agree with you 100%... most likely, the ring land on the piston has cracked from detonation.. If you look closely at the plugs, it "looks" as those you can see a little bit of piston material on them... if you were to take a zoomed photo with the oil wiped off, it may be more evident... hopefully you can reuse your crank (i would toss the pistons and rods as im sure the wrist pins are no longer round from the pounding).

good luck!
 

Blood on Blood

rumble baby rumble
Joined
Apr 6, 2005
Messages
36,431
Reaction score
220
Unfortunate incident; however, I am glad you are documenting everything so that others can learn.

Your example is the reason I have not installed a Procharger on the Mach 1. The rods and pistons in my Mach 1 are garbage and blowing the motor is not a matter of if, but when.

You keep posting and I will keep reading. If there is anything I can do or someone I can talk with to help negotiate, let me know.

Dave
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
i would agree with you 100%... most likely, the ring land on the piston has cracked from detonation.. If you look closely at the plugs, it "looks" as those you can see a little bit of piston material on them... if you were to take a zoomed photo with the oil wiped off, it may be more evident... hopefully you can reuse your crank (i would toss the pistons and rods as im sure the wrist pins are no longer round from the pounding).

good luck!
i'kk take pics of the plugs w/o the oil
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
Blood on Blood said:
Unfortunate incident; however, I am glad you are documenting everything so that others can learn.

Your example is the reason I have not installed a Procharger on the Mach 1. The rods and pistons in my Mach 1 are garbage and blowing the motor is not a matter of if, but when.

You keep posting and I will keep reading. If there is anything I can do or someone I can talk with to help negotiate, let me know.

Dave
Thanks Dave :)
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
i would agree with you 100%... most likely, the ring land on the piston has cracked from detonation.. If you look closely at the plugs, it "looks" as those you can see a little bit of piston material on them... if you were to take a zoomed photo with the oil wiped off, it may be more evident... hopefully you can reuse your crank (i would toss the pistons and rods as im sure the wrist pins are no longer round from the pounding).

good luck!


 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
95trippleblackconv said:
Mikey
Did you have the breather line from the valve cover to blower inlet hooked up.
Yes, everything was hooked up as it should be.
 

zenriddles

Molon Labe - come and take them!
Joined
Aug 18, 2005
Messages
3,217
Reaction score
44
Location
Holiday Inn
I agree on a smoked piston.

Why? . . .

I looked over your list of mods. I see a glaring ABSENCE of fuel system upgrades.

You went lean.
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
zenriddles said:
I agree on a smoked piston.

Why? . . .

I looked over your list of mods. I see a glaring ABSENCE of fuel system upgrades.

You went lean.
I have 42/lb injectors and SCT MAF. forgot to put that in my sig.
 

Bob_Kurgan

Flyin_Hawaiin
Joined
Feb 16, 2005
Messages
3,013
Reaction score
0
VenomInside said:
again, this is WHAT I THINK I SEE..

on the flat of the plug, it looks as though you can see some piston... if you take your fingernail, do the little specks rub off or are they melted on?
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
again, this is WHAT I THINK I SEE..

on the flat of the plug, it looks as though you can see some piston... if you take your fingernail, do the little specks rub off or are they melted on?
Some of it rubs off and some seems to be melted on.
 

VenomInside

Just Grazing
Joined
Jul 16, 2004
Messages
24,209
Reaction score
8
Location
SFO
UPDATE

Well, Got more done with the help of Erik (aka MGT2002) and my girlfriend who helped out as well. Turns out she is mechanically inclined ;)

Anyway..

Got the spark plug wires etc off, blower, brackets, coolant res, intake manifold etc etc etc..

Btw, THANKS ERIK for coming out again :headbang:































 

rdsnake

formerly RD SNAKE
Joined
Mar 5, 2006
Messages
5,571
Reaction score
26
Mikey, Your not going to like what im going to tell you but....I belive those supercharger's run off engine oil, basicly when you pop your engine you send all of that metal and crap thur the s/c and it works the other way around. Id send out the blower to get it checked out. I wouldn't want to cash a new engine.

Kevin
 

Blood on Blood

rumble baby rumble
Joined
Apr 6, 2005
Messages
36,431
Reaction score
220
Well if the supercharger is toast, then you are really starting over, especially since the transmission is stock and probably on life support.

As a result, might I suggest a 347 or 408, accompanied with a supercharger/turbo kit (your choice) and a TKO 600. :biggthump


Dave
 

imbuggin

Well-known member
Joined
Mar 15, 2007
Messages
541
Reaction score
0
i may have missed it

I may have missed it, but were you running and intercooler?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom