Dying injector?

Aron

Scared pussy
Joined
Sep 1, 2005
Messages
13,971
Reaction score
5
Having an intermittent problem with a misfire. Car runs and drives fine on cold start, but on hot restarts it misfires as soon as I start it, and SES flashes when driving. Had my codes checked, had a code for cyl 4 injector and cyl 4 misfire. Oh and EVAP too (also have intermittent "check gas cap" message). I got my voltmeter out and see voltage for the pulse, but found no ohms from the injector when hot. When I check it cold I get around 13-14 ohms.

Is it common for an injector to die like that when hot? What is a suitable replacement injector? It's an all stock 04 GTPCG and from what I read it's a 33# stock.
 

ZephTheChef

Well-known member
Joined
Mar 2, 2014
Messages
835
Reaction score
0
Location
Wichita, KS
Having an intermittent problem with a misfire. Car runs and drives fine on cold start, but on hot restarts it misfires as soon as I start it, and SES flashes when driving. Had my codes checked, had a code for cyl 4 injector and cyl 4 misfire. Oh and EVAP too (also have intermittent "check gas cap" message). I got my voltmeter out and see voltage for the pulse, but found no ohms from the injector when hot. When I check it cold I get around 13-14 ohms.

Is it common for an injector to die like that when hot? What is a suitable replacement injector? It's an all stock 04 GTPCG and from what I read it's a 33# stock.
Make a trip to the junkyard and just get another stock injector unless you're looking to replace the whole set/upgrade.
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
yeah, its common enough i had to replace one on my CompG when it opened internally

pretty sure i have 5 more in a box somewhere in the garage
 

98GrandPrixIraqVet

Well-known member
Joined
Jan 26, 2015
Messages
14,069
Reaction score
78
Location
Nowheresville North Dakota
Damn its a comp g i have 6 stock 04 NA injectors sitting in my garage and 6 stock 97 gtp injectors too.

i dont think any of them would work.

im not 100% sure if any of those would work i could mail you some this weekend.

:dunno:

edit james beat me.
 

Aron

Scared pussy
Joined
Sep 1, 2005
Messages
13,971
Reaction score
5
Cool thanks guys.

James, how much you want for one of yours if I can't find one in my local u pull it? [MENTION=53]Turbocharged400sbc[/MENTION]
 

Aron

Scared pussy
Joined
Sep 1, 2005
Messages
13,971
Reaction score
5
I put a multimeter on the injector and got 14/15 ohms cold and it ran fine. Drove it, got it hot to the point it started misfiring, got 0ohms from injector. Im pretty confident that is my problem
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
i found the bad one that i yanked out, the good ones must be nearby if my filing system wasnt fucked up by kevin cleaning
 

boostedguy05

not well known
Donating Member
Joined
Dec 18, 2010
Messages
21,714
Reaction score
367
:rofl:

now that you have room, i should bring you those tie rod end links and spark plug wires.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom