Dreaded SECURITY Light Flashing...Car Not Running Problem

CHI2000GTP

Grand Prix Junkie
Joined
Dec 1, 2017
Messages
400
Reaction score
18
Location
Chicago, IL
Well, looks like the ignition is on its way out in my Blue Turbo Prix. From what I gather, it's a common problem in these cars. The car cranks and runs for about 3 seconds, then dies. Security light flashing the entire time. I tried the security re-learn, it didn't work. I kinda half-assed it though so maybe I will try again.

Question is this: Where do I start? Do I replace the Ignition Switch? and/or the Tumbler? The "Ignition Switch" when Google'd, brings up what is basically the Ignition Harness. Is there anything else that I'm missing that needs to be replaced?

The tumbler has all kinds of issues. It doesn't release the key 50% of the time, and you can pull the key out while driving. It has zero effect on the car, but clearly shouldn't be happening. One time, cruising down the highway with the kids, I pulled the key out...and they were freaking out!! LOL. Blew their minds! Haha.

Or, does anyone know of a different way to quickly bypass the system?

Also... There are places that rebuild tumblers. Which would allow me to keep the same 1 key, instead of needing 2 keys now (doors/ignition).

Thoughts on all this?
 

1quick

Well-known member
Donating Member
Joined
Jan 29, 2008
Messages
19,932
Reaction score
447
Location
coal city
Does your key have the resistor deal in it, my 98 regal had a resistor on the metal part of the key if it got dirty the security light would flash and the car wouldn’t start
 

crooks

Well-known member
Donating Member
Joined
Sep 30, 2012
Messages
3,213
Reaction score
118
Location
Elgin IL
Has the car ever had an aftermarket remote start?
 

CHI2000GTP

Grand Prix Junkie
Joined
Dec 1, 2017
Messages
400
Reaction score
18
Location
Chicago, IL
Does your key have the resistor deal in it, my 98 regal had a resistor on the metal part of the key if it got dirty the security light would flash and the car wouldn’t start
No resistor on this key. Key for my other Grand Prix doesn't have a resistor either. Heard of that though. Must be a Regal only, W-body thing.


Has the car ever had an aftermarket remote start?
No. No after-market remote start or after-market alarm.
 

Yaj Yak

Harbor Master
Donating Member
Joined
May 24, 2007
Messages
90,368
Reaction score
1,291
the resistor is in the actual key head
 

Yaj Yak

Harbor Master
Donating Member
Joined
May 24, 2007
Messages
90,368
Reaction score
1,291
This worked. She's a purrin. Thanks brah!
okay sweet.

i had only remembered that because i once broke my only gtp key off in the trunk lock, had to get a new one cut, then program it using something like this.

glad it worked :bigthumb:
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom