Dodge proficient people needed

gojo83

Well-known member
Joined
Jun 11, 2009
Messages
235
Reaction score
0
Location
Cheyenne WY
So a buddy that is not well off asked for some help, 1997 dodge intrepid 3.5.
Has a jy fresh fuel pump and it has a walbro stamp on the canister so I think that the pump would be good. So I pretty much ruled out the FP but when you get up near the fuse block you can hear and feel a clicking in the FP relay so swapped it to a spare relay from another car and it still does the same thing. the thing that gets me is the car also has a junkyard fresh coil pack, but I ran my test light to the plug wire and it was as if the plug wire wasnt getting any juice but the connector to the coil is good and getting juice. I hit it with a little starting fluid and it wanted to kick over but didnt. I am getting to the point where I am debating tossing a rag in the gas filler neck and letting the bitch burn but I cant since its not my car. ANY help would be awesome.
 

bikrboy128

Some say.....
Joined
Jul 15, 2007
Messages
10,671
Reaction score
76
Location
Wheaton
get an actual spark tester, see if it's getting spark. also get a fuel pressure tester, see what kind of fuel pressure it's getting. check the ASD (auto shutdown) relay too
 

gojo83

Well-known member
Joined
Jun 11, 2009
Messages
235
Reaction score
0
Location
Cheyenne WY
well after playing with it and a fresh set of eyes from a buddy it appears the coil pack is dead we have fuel presssure of 50ish and then we figured out the issue with my white car but that is for another thread. stupid wbody engine mounts
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom