coolant tank/hose no pressure

breeze

Active member
Joined
Apr 10, 2012
Messages
38
Reaction score
0
Drove home from work checked coolant tank on flat ground twisted cap off and didn't have a ounce off pressure behind it and was a bit on cooler side . Felt the hoses and could squeeze them so no pressure there either. Pulled up on incline and twisted co tube cap and coolant wanted to come out. Cars not over heating, have ac and heat but something doesn't seem right. Past 2 days I could hear noise under hood as I walked to it while it was running and today smelt coolant ass I walked into work. Do I have something or not?
 

massacre

Well-known member
Joined
May 25, 2011
Messages
158
Reaction score
0
replace with known good cap see if it holds pressure?
Is this stock-style system or something different?
 

breeze

Active member
Joined
Apr 10, 2012
Messages
38
Reaction score
0
replace with known good cap see if it holds pressure?
Is this stock-style system or something different?
Bought new cap earlier from AutoZone. Only driving was back home with new cap about 3 miles. Will see what happens tomorrow going to work and class.

Before I bought new cap it did build slight pressure in hose and coolant tank.
 

breeze

Active member
Joined
Apr 10, 2012
Messages
38
Reaction score
0
With new cap had pressure but could squeeze. Don't remember how much pressure its supposed to have. Then dribbled out of the bleeder so I put permitex on threads. No more dribble out of c/o tube but haven't checked it really since. Tomorrow I'll check, maybe I'll just replace tstat.
 

breeze

Active member
Joined
Apr 10, 2012
Messages
38
Reaction score
0
Will do. Learned that the hard way a year ago, costly mistake!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom