Comp G problems. GP people step in, PLZ.

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,162
Reaction score
36
Location
Chicago (Southside)
Alright guys, I'm looking for things to check. I really have no idea where to begin.

First, I recently had the LIM gasket r&r'd at a dealer under my aftermarket warranty among a few other things like the wheel bearing, and endlinks.

Now, yesterday I was driving to work and as I came to a stop from ~60mph the car started to surge. I get to the stoplight, and all is well, but then when I went to take off the car would hesitate, accelerate, hesitate some more, and then continue accelerating. Once I got past around 2500-3000 rpm or so the car was fine. But whenever I'd let off the car would hesitate and then almost want to stall.

I pulled over, put the car in park and then I heard what I would describe as having a big lopey cam. My car was doing a glub glub glub glub glub.... (the SES light wasnt flashing, but was on) sorta thing. I shut it off, and then restarted it and it started fine, seemed fine until I put it into gear and went to take off and it started to hesitate. I went to continue my trek to work, and once I got back above 3k all was fine, so figuring aslong as I kept the rpms up that high, I could make it back to work to diagnose the problem.

WELLLLL.. After about 3 more minutes I recieved some chimes then on the DIC I saw "Service Traction System" then "Service Stability System" and then lastly "Reduced Engine Power" and by this time I was already doing 60, and when I saw the last error pop up I went to accelerate to get over and pull off to the side when I noticed that now the car wasnt responding to my throttle input whatsoever. After about 5 seconds the car then just stalled out. I managed to make it off the road and went to restart it and nada, it just crank and crank and cranks.

So I had it towed back to work, tried restarting it, and it started, displayed "Reduced engine power" and the "Service Traction System" ran for about 20 seconds, started to chug, and then died out. I go to restart it and it just cranks and cranks. If I let it sit for 10 minutes, it'll restart, but if I try right after that it'll only crank.

I scanned the car for codes with a generic MAC tools scanner and it stated a P01### code (I forgot the number) and the scanner said it was a MAF/MAP/Throttle code. I went to reread it and accidently ended up deleting it, but if I saw the code again I'd probably know what it was.

I tried starting the car with the MAP unplugged, same thing, MAF unplugged, same thing, and the Elec.TB unplugged, and of course same thing. I did notice however that the rubber T under the supercharger was broken and had been taped by the dealer that did my LIM repair. Oh and it was actually broke off again and I do not have an idea on how long its been like that (could be up to a week).

Any ideas where I could check? I will be sending the car back to the dealer, but I would just like to have an idea what it could be.

Thanks
-Nick
 

PANDA

Well-known member
Joined
May 24, 2007
Messages
34,398
Reaction score
159
Location
FRG
If the rubber T is broken you probably have a vacuum leak
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom