Boost issue or not??

Dragon03

Super hated on
Joined
Mar 28, 2007
Messages
27,350
Reaction score
0
Going home from work yesterday getting onto the highway I punched it and saw that my boost gauge ( mechanical autometer) read out close to 20psi:scared:.....I immediatley got out of it and poop'd home driving like granny. I have the car set for 17psi and that was the first time it has done that.....so question I am running a 2.3 1st gen whipple and the way I see it there are 2 options either the gauge took a dump or something went south with the blower.....from what I understand there are no purge valves just a boost bypass that bleeds off the boost between shifts? Any thoughts vaccum sits right at -20 so there does not appear to be any engine issues...:dunno:
 

1quick

Well-known member
Donating Member
Joined
Jan 29, 2008
Messages
19,929
Reaction score
447
Location
coal city
if you havent changed anything with the cars set up its prolly the gauge, the only things that ive seen that will make a supercharged car show more boost is cooler temps, or adding back pressure to the exhaust
 

Dragon03

Super hated on
Joined
Mar 28, 2007
Messages
27,350
Reaction score
0
thats kinda what my thought was pulley is what makes things happen...just scared the shit outta me seeing that I just had vision of seeing piston rocketing out of the hood when that happened:smile:
 

IZZy

Powered by ES
Joined
Dec 15, 2007
Messages
38,986
Reaction score
2
Pink car finally making some boost... Dont be skurred
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom