3.3 running rough

nick122590

Well-known member
Joined
Jul 10, 2011
Messages
2,008
Reaction score
3
Location
IOWA
92 century. Saturday I did a complete TuneUp and brakes. Car ran perfect Saturday and Sunday. Today its running extremely rough at idle and when driving at lower rpms the car vibrates horribly. But if I raise the rpms it gets better and letting off completely it stops. Where the fuck should I even start?
 

Dasfinc

Mrrrrstang.
Joined
Sep 28, 2007
Messages
20,480
Reaction score
5
Location
Wheaton, IL
Detail exactly what you did in a "Complete Tune Up".

Coil pack/Dizzy/Cap/Rotor? O2s? Seafoam?
 

nick122590

Well-known member
Joined
Jul 10, 2011
Messages
2,008
Reaction score
3
Location
IOWA
All fluids and filters plugs wires 02s . Coil packs are only a few months old.
 

Dasfinc

Mrrrrstang.
Joined
Sep 28, 2007
Messages
20,480
Reaction score
5
Location
Wheaton, IL
All fluids and filters plugs wires 02s . Coil packs are only a few months old.
It was very nice the past few days, humidity spiked last night with the brief rain at least in my area.

Coil packs do have a high infancy death rate, and humidity will often bring out the worst in them if there is a crack etc, so that is a possibility. :dunno:

Also check wires for burn marks/seperation :smile:
 

bikrboy128

Some say.....
Joined
Jul 15, 2007
Messages
10,652
Reaction score
57
Location
Wheaton
92 century? start by junking it :rofl:

i'd check for vacuum leaks. all the vac lines are probably dry rotted, and you probably bumped one while doing your tune up.
 

nick122590

Well-known member
Joined
Jul 10, 2011
Messages
2,008
Reaction score
3
Location
IOWA
92 century? start by junking it :rofl:

i'd check for vacuum leaks. all the vac lines are probably dry rotted, and you probably bumped one while doing your tune up.
And why the fuck should I junk it? I paid a grand for it and this is the first time its given me trouble. I've put over 20k miles on it. Driven to Iowa and back.
 

nick122590

Well-known member
Joined
Jul 10, 2011
Messages
2,008
Reaction score
3
Location
IOWA
you paid a G-note for a 92 century?
What's wrong with that? I got it with 54k miles



Finally went out and checked. Wire was resting on the o2 sensor. Archin like a mofo lol
 

Dasfinc

Mrrrrstang.
Joined
Sep 28, 2007
Messages
20,480
Reaction score
5
Location
Wheaton, IL
What's wrong with that? I got it with 54k miles



Finally went out and checked. Wire was resting on the o2 sensor. Archin like a mofo lol
anything that runs/drives is really worth a grand, so a 54K example of a buick is a pretty good pickup IMO...

Granted you couldn't pay me a grand to drive it :bowrofl:

Glad you found your issue quickly!
 

nick122590

Well-known member
Joined
Jul 10, 2011
Messages
2,008
Reaction score
3
Location
IOWA
anything that runs/drives is really worth a grand, so a 54K example of a buick is a pretty good pickup IMO...

Granted you couldn't pay me a grand to drive it :bowrofl:

Glad you found your issue quickly!
its ugly but i love it. seats are so damn comfy. and it has some good top end. ask your buddy s00ls my car walks him
 

Slow Buick

eat ass drive fast
Joined
Sep 10, 2007
Messages
24,441
Reaction score
6
nice. I'm gonna have Tim swap out my front o2 sensor. I have no way to get under the car enough to get it and no real way to get at it from the top.
 

SaturdaysGS

Well-known member
Joined
Jul 15, 2007
Messages
4,134
Reaction score
12
Location
Chicago (Southside)
nice. I'm gonna have Tim swap out my front o2 sensor. I have no way to get under the car enough to get it and no real way to get at it from the top.
Take off the upper dog bones, ratchet strap engine forward and watch your hands/wrists for the exhaust gasket between the downpipe and exhaust manifold. Should be enough room. Or atleast someone with smaller hands (no offense -don't know about yours) as mine are on the smaller side. :rofl:
 

DanJoy

Well-known member
Super Moderator
Joined
May 25, 2007
Messages
28,338
Reaction score
118
Location
Aurora
Get that guy from Tale of the Crypt Keeper to wrench on your car. Could have all 3 rear plugs changed in 5 minutes without moving the engine.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom