03' Grand Am GT MAF Issues

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
Car is an 03 GT with the 3400, it was throwing an intermediate p0101 code so I changed the maf also threw in a new air filter. now I have p0101 and p0102, when i drive it around town I can't get the lights to come back after I reset them and the car drives perfect. However she drove the car maybe 20 miles a little more and she explains that it dies when slowing down, either backfire or misses and smells like rotten eggs. Getting about 23 mpgs. I inspected the ground and for the MAF circuit and it visually looked fine. I'm curious if I might be dealing with a clogged cat. Thoughts?? Thanks
 

boostedguy05

not well known
Donating Member
Joined
Dec 18, 2010
Messages
21,843
Reaction score
464
did you make sure it was plugged in............
 

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
also mind you, I do not have a visible CEL, I found the codes by checking the codes on the handheld
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
the upstream O2 is easy to remove, then test drive with it unplugged and see if power picks up. the vac test is checking idle vac and part throttle load. if manifold vac drops to near zero at less than 100% throttle/100% load then exhaust is restricted
if its over 120k then its even more likely its plugged or nearly plugged
 

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
the upstream O2 is easy to remove, then test drive with it unplugged and see if power picks up. the vac test is checking idle vac and part throttle load. if manifold vac drops to near zero at less than 100% throttle/100% load then exhaust is restricted
if its over 120k then its even more likely its plugged or nearly plugged
It stayed at 20hg at idle and at 2500rpm
 

Turbocharged400sbc

Welllllllllll ya knowwwwwww.....
Joined
Jun 16, 2007
Messages
26,499
Reaction score
12
Location
hangover park IL
under load or just high idle in p/n, you need to be loaded, tape gauge to windshield while driving

a broken cat is more likely to cause an intermittent restriction, smack the converter with a mallet /gloved palm and listen for a rattle
 

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
Okay, I was in park during the test, I'll get at it tomorrow, thank you for the insight. I feel like this is what the issue is. Just odd I'm not throwing a code at the 02 or iirc there should be a failed cat code as well
 

RICH17

Dr. Pussy Slayer, MD
Donating Member
Joined
Nov 14, 2008
Messages
25,938
Reaction score
188
Location
The 007
Whats the mileage? The cat always seem to go bad around 120k
 

RICH17

Dr. Pussy Slayer, MD
Donating Member
Joined
Nov 14, 2008
Messages
25,938
Reaction score
188
Location
The 007
Yea I bet it is a bad cat. I've seen several plugged cat cars with the same symptoms all around that mileage.
 

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
The tits of this ride lasted about a week or two, although the dying was more intermittent it was still happening, swapped the maf again tested for plugged cat, inspected wiring and grounds, only notable find was a dry rotted pinched vac hose for the evap purge. Today was it's worst dying at every stop so I limped to Chevy and they diagnosed ecu. Bleh
 

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
Ecu swapped and it was bum, threw oe back in and car ran without codes. No explanation. Drove it home died again about 30 min away from shop. Faauuuccck
 

Bub

Pitter Patter
Donating Member
Joined
Sep 4, 2012
Messages
12,508
Reaction score
163
Location
Pistakee Highlands
Now shop is thinking the torque converter is slipping or something. Idk some gm bulliten this car needs to burn
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top Bottom