User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 05-07-2010, 08:06 AM   #1
Mazarin's Avatar
80's Tech Fan
 
Join Date: Mar 2010
Location: Schaumburg
Posts: 19
80's Tech Fan
 
Mazarin's Avatar
 
Join Date: Mar 2010
Location: Schaumburg
Posts: 19
Casino cash: $4611400
0.01 per day
Default FS: 84 Mitsubishi Starion(Chrysler Conquest) - T3/T4 Turbo - $2000 (Schaumburg)

Due to financial circumstances beyond my control, I must sell.

I've got a daughter due any second - I was hoping that I'd be able to support both, but that's not the case, so baby before car.

The good:
CA/AZ car - minimal rust, have not removed the mudgaurds so there could be some under there. The driver's side front fender might have the worst of it, but nothing a little kitty hair and POR-15 can't solve.
This was an 87 engine. Good compression in all 4. Drove it 700mi from middle-of-nowhere KS to Chicago w/o any serious issue. Just takes a sec to warm up.
3"GM MAS w/ MAF-T
T3/T4 turbo w/ ex. wastegate @ 6psi
Log-style exhaust mani
3" DP/exhaust to Tenzo fart cannon(scilenced - needs replacing)
Clutch and trans are great. Everything grabs nice and shifts are strong and smooth.
Interior is nice. I'm in the middle of a pseudo-buckskin conversion. Replacement rear seatbacks and other black pieces are included.
Digital dash conversion(original speedo incld)
VELNAS - the MPGs are a little wonky, but everything else reads great.
Plenty of tread on the tires
New brakes
Swapped headlights to accept H4 bulbs
Replaced antenna mast w/ a stubby

The bad:
I've got a sputter I cannot figure out. It seems completely random. I've replaced the O2 sensor and had the MAF-T tuned. I've reset the TPS. I just replaced the injector clips w/ Dad's Bosch clips. I've checked several connections and have another ECU I haven't checked/tried.
The ICS wasn't connected when I got the car. I rewired it and warm starts are easy w/ just a little throttle - probably needs another reset.
Rear main seal is leaking. Was installed backwards. Leaks oil from that spot. Maybe needs a quart a month.
Turbo probably needs to be replaced/rebuilt. I'm getting some blue smoke @ low idle.
Steering coupler is worn - has steering play
Needs a repaint. Most of the panels are straight. Header panel is borderline, but I think can still be saved(no rust, just alot of dents)
Right turn signal doesn't click(but does light up - needs center bulb replaced)

The other:
Chassis has over 204K/mi
Engine has 70K on it
Has sunroof - has good seal that isn't coming apart. The dial doesn't seem to catch so it's either closed or off - no in-between.
No ABS
No AC
Does have power steering. It's in a box along w/ other parts(like the 2nd ECU, inj clips, other int and misc parts.)
Heater core has been bypassed
It's a flatty - so it's non-intercooled BUT I've got all IC pipes and an intercooler(w/ a cut pipe) for the conversion.
The BRAKE light never turns off
Car was never registered in IL - still has the AZ title. Car doesn't need to be smogged in IL due to age.

If I can think of anything else(I tried to think of ANYTHING possible that'd be an issue/of interest), I'll put it up here.

I'm looking for $2000. I'd love to continue fixing her, but I just don't have the money(and soon, no time) to continue, but this car is close and it'll prolly tick me off slightly(and then be happy) when I see the kind soul who purchases this car get it to where she should be.

You can call me @ 224-201-0919(ask for Eric after 6PM CST) or PM. Car's gotta go, and if I can't sell this weekend, she's going up on eBay
















__________________


First one: Red 88 - 245whp/312wtq - HIN: Nightshift - Chicago '07 WINNER
This one: White 84 Flatty - T3/T4 - GM MAS/MAFt - VELNAS - RUNNING AND FIXED(I think)
Daily: 2005 Jaguar X-Type 3.0 Sport

"...Remember: Don't crush 'em, restore 'em!"
Mazarin is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:44 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
no new posts