User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-25-2007, 04:29 PM   #1
grey03svt's Avatar  
Join Date: Dec 2004
Posts: 43
 
grey03svt's Avatar
 
Join Date: Dec 2004
Posts: 43
Casino cash: $4610000
0.01 per day
Default cobra overheating!!! plz help!!!

My car was idleing for about 10mins when i noticed my temp gauge was pegged on hot!

I checked out under the hood and what I found was the right side of the radiator (looking at the motor) was cold... But the left side of the radiator was way to hot to touch...rain drops were sizzling on it!

My heat blows out cold also...

Sounds like thermostat??? I have a 160 degree t-stat that i could toss in, but am not sure if it's ok to do or if i need a retune???
grey03svt is offline   Reply With Quote
Old 04-25-2007, 05:10 PM   #2
Bullitt-1469-'s Avatar  
Join Date: Jun 2005
Posts: 406
 
Bullitt-1469-'s Avatar
 
Join Date: Jun 2005
Posts: 406
Casino cash: $4611500
0.08 per day
Default

Yeah that sounds like the thermostat, the cobra uses a 188 degree which is what most people run. Make sure when you refill the coolant that the heats on a blasting. BTW when I filled mine up after it took 4 hours to burp out.
__________________
1995 Tahoe (SOLD)
1995 Talon tsi (SOLD)
1995 Talon tsi (SOLD)
1999 Cobra VERT (SOLD)
2001 Mustang Bullitt (SOLD)
1999 Dodge Dakota CC (current DD)
2003 Saleen Hollwood Horsepower (SOLD)
Bullitt-1469- is offline   Reply With Quote
Old 04-25-2007, 05:22 PM   #3
rdsnake's Avatar
formerly RD SNAKE
 
Join Date: Mar 2006
Posts: 5,529
formerly RD SNAKE
 
rdsnake's Avatar
 
Join Date: Mar 2006
Posts: 5,529
Casino cash: $18337200
1.12 per day
Default

Quote:
Originally Posted by Bullitt-1469-
I filled mine up after it took 4 hours to burp out.

Took me about 6 "burping" cycles over the course of 2 days....what a drag...

Kevin
__________________
2015 GMC Denali Druamax
-Delete and tuned

2016 Polaris RZR turbo

2017 Civic Touring
rdsnake is online now   Reply With Quote
Old 04-25-2007, 05:25 PM   #4
grey03svt's Avatar  
Join Date: Dec 2004
Posts: 43
 
grey03svt's Avatar
 
Join Date: Dec 2004
Posts: 43
Casino cash: $4610000
0.01 per day
Default

i hope it's the t-stat... im still waiting on a tune for the 160 to finish up... the only thing is, i put the factory t-stat in boiling water and it opened up all the way.....
grey03svt is offline   Reply With Quote
Old 04-25-2007, 05:43 PM   #5
rdsnake's Avatar
formerly RD SNAKE
 
Join Date: Mar 2006
Posts: 5,529
formerly RD SNAKE
 
rdsnake's Avatar
 
Join Date: Mar 2006
Posts: 5,529
Casino cash: $18337200
1.12 per day
Default

Quote:
Originally Posted by grey03svt
i hope it's the t-stat... im still waiting on a tune for the 160 to finish up... the only thing is, i put the factory t-stat in boiling water and it opened up all the way.....
the stat could be stick open/closed just a little bit. They are so cheap id replace it and stop worring about it.

It could be air in the system/low coolant also

Pressure test the system and check for leaks

Refill and bleed CORRECTLY, the slightest bit of air will send the temp gauge stright into the red..
rdsnake is online now   Reply With Quote
Old 04-25-2007, 05:58 PM   #6
grey03svt's Avatar  
Join Date: Dec 2004
Posts: 43
 
grey03svt's Avatar
 
Join Date: Dec 2004
Posts: 43
Casino cash: $4610000
0.01 per day
Default

Quote:
Originally Posted by RD SNAKE
the stat could be stick open/closed just a little bit. They are so cheap id replace it and stop worring about it.

It could be air in the system/low coolant also

Pressure test the system and check for leaks

Refill and bleed CORRECTLY, the slightest bit of air will send the temp gauge stright into the red..

no one but the dealer around here has a t-stat, and they are closed now...

i wonder if it would be wise to put in the 160 without a retune...or if i even need one?
grey03svt is offline   Reply With Quote
Old 04-25-2007, 06:08 PM   #7
cyac5l8trfcar's Avatar
{'''}o_o{'''}
 
Join Date: Sep 2005
Posts: 2,722
{'''}o_o{'''}
 
cyac5l8trfcar's Avatar
 
Join Date: Sep 2005
Posts: 2,722
Casino cash: $4610000
0.53 per day
Default

these things take forver to "burp". Sounds like a burp for sure. Just let the car idle with the radiator cap off. I don't know where the high spot is on '03s but there might be a threaded plug somewhere you need to take out. One of the termi gurus will chime in shortly and help you out more.
__________________
Quote:
No matter the industry, especially Corp. America, you are either giving a blow or taking it in the ass. How well you are liked is what determines if you get fair warning and a jar of vasoline to lube yourself up with.
cyac5l8trfcar is offline   Reply With Quote
Old 04-25-2007, 06:13 PM   #8
grey03svt's Avatar  
Join Date: Dec 2004
Posts: 43
 
grey03svt's Avatar
 
Join Date: Dec 2004
Posts: 43
Casino cash: $4610000
0.01 per day
Default

Quote:
Originally Posted by cyac5l8trfcar
these things take forver to "burp". Sounds like a burp for sure. Just let the car idle with the radiator cap off. I don't know where the high spot is on '03s but there might be a threaded plug somewhere you need to take out. One of the termi gurus will chime in shortly and help you out more.
ya, ive burped this thing a million times.. the high point is on the crossover tube next to the blower. im just confused on why it would be air all of the sudden after about 4 months since the last time i burped it....
grey03svt is offline   Reply With Quote
Old 04-26-2007, 12:15 PM   #9
Sharkster's Avatar  
Join Date: Sep 2005
Posts: 633
 
Sharkster's Avatar
 
Join Date: Sep 2005
Posts: 633
Casino cash: $4613300
0.12 per day
Default

I just refilled mine the other night and whamoooo that damn thing burped and I had coolant everywhere
__________________
2004 Screaming Yellow Cobra Coupe

--------------------------------------
Sharkster____________
2004 Torch Red Cobra Coupe
Twin 57's..... SOLD
Sharkster is offline   Reply With Quote
Old 04-26-2007, 01:28 PM   #10
Bullitt-1469-'s Avatar  
Join Date: Jun 2005
Posts: 406
 
Bullitt-1469-'s Avatar
 
Join Date: Jun 2005
Posts: 406
Casino cash: $4611500
0.08 per day
Default

Make sure you use a ford stat because most after markets suck, I did it twice because the car quest stat was DOA, there goes more time and expensive coolant!

The high spots in the 03 motor is the back driver side head, thus why they made a cooling mod to solve the flow issue.

If you dont have one then try jacking the car up from the front and put in the coolant, and also make sure your filling it from the WATER TUBE not the coolant tank.
Bullitt-1469- is offline   Reply With Quote
Old 04-30-2007, 12:30 AM   #11
grey03svt's Avatar  
Join Date: Dec 2004
Posts: 43
 
grey03svt's Avatar
 
Join Date: Dec 2004
Posts: 43
Casino cash: $4610000
0.01 per day
Default

ok, i put in a factory t-stat. everthing is back to normal!! (knock on wood)... thanks for all the help guys!
grey03svt is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
no new posts