User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-22-2007, 12:39 PM   #1
Sharkster's Avatar  
Join Date: Sep 2005
Posts: 633
 
Sharkster's Avatar
 
Join Date: Sep 2005
Posts: 633
Casino cash: $4613300
0.12 per day
Default Im done for a while

Backed it out of the garage today. Adjusted the coilovers even and higher. Backed it out and the motherfucker dropped way down again. I havent got a clue. Obviously not adjusted up high enough. One wheel will angle in while the other is straight (have no clue how that happened.. maybe when I undid the steering bolt) Fuckin alignment is so fucked I dont dare take it farther than 2 squares on the drive or buy new BF DRs for sure Ive got nobody here in town that does alignments AT ALL.... can you fucking believe that. These fixit shops and none of them do this..... WHATEVER. I dont have a truck or a trailer to get it to Janesville to get this done.
Ive got a small damn oil leak on the timing cover top on the edge under the valve cover. Bracket that goes goes on the outer bolt was pushed back and the flat portion was stuck in between the goddamned valve cover and timing cover when the cover went back on and created a nice gap. Guess what has to come off and get resealed. Brakes are kind iffy right now as they just went to the floor and I checked them again and now they seem ok.
The turbos are building no boost, my idle is fucked at between 1500-1800rpms with a little smoke out the pipes. My Greddy, at idle shows me -.65 on vacuum so Im guessing one hell of a leak somewhere. I found one where my IAT2 sensor was not sealed up. Now its sealed up and Im showing that -.65 vacuum level. I was going to use some carb cleaner to find the vacuum leak however Ive never done this before and this is the first Ive heard of doing this. STOP you know how hot and fast these turbo headers heat up to that of a mild arc welder. Great thats what I need a damn flash fire and its an insurance claim.
Here are some updated photos I took about 30 minutes ago. Now Im going to clean up my garage and push this fucker back in there and let it set until next month. Im all out of patience and money at this point and am limited on where I can go for help for issues I dont know or understand. Ive got other issues to address around my house that are more important than this car. Maybe next month!!!!!!!


Im venting
http://s127.photobucket.com/albums/p143/sharkster_2007

Wow did I really say all of that MY APOLOGIES Im frustrated ahhhhhhhhh
__________________
2004 Screaming Yellow Cobra Coupe

--------------------------------------
Sharkster____________
2004 Torch Red Cobra Coupe
Twin 57's..... SOLD
Sharkster is offline   Reply With Quote
Old 04-22-2007, 01:58 PM   #2
Mr. Unknown's Avatar  
Join Date: Oct 2005
Posts: 0
 
Mr. Unknown's Avatar
 
Join Date: Oct 2005
Posts: 0
Casino cash: $4611500
0 per day
Default

I can say i feel your pain.
Mr. Unknown is offline   Reply With Quote
Old 04-22-2007, 02:20 PM   #3
WhtSuperStang's Avatar
Jack Bauer > Chuck Norris
 
Join Date: Jun 2005
Posts: 4,728
Jack Bauer > Chuck Norris
 
WhtSuperStang's Avatar
 
Join Date: Jun 2005
Posts: 4,728
Casino cash: $4610000
0.92 per day
Default

wow man sorry to hear your having all the problems good luck with everything!
WhtSuperStang is offline   Reply With Quote
Old 04-22-2007, 04:28 PM   #4
Painter's Avatar  
Join Date: Mar 2004
Posts: 1,166
 
Painter's Avatar
 
Join Date: Mar 2004
Posts: 1,166
Casino cash: $4610000
0.21 per day
Default

Hey man take a deep breath.............I have had alot of the same problems but these things take alot more time to get correct than we think. Try about 4 times the amount of time. I was at the point of wanting to crash it into a tree, Going turbo is not the easiest of things, ESPECIALLY twins. Just take a break and have a Mai Tai while looking at asian anal online..........that might reduce the stress
Painter is offline   Reply With Quote
Old 04-22-2007, 06:43 PM   #5
ShelbyGuy's Avatar
Turgid Member
 
Join Date: Mar 2004
Posts: 5,231
Turgid Member
 
ShelbyGuy's Avatar
 
Join Date: Mar 2004
Posts: 5,231
Casino cash: $4610000
0.93 per day
Default

we can fix your brakes and alignment in your driveway. i can make a car track straight down the road with some string, a tape measure and a carpenter's square. the brakes probably just need to be bled (including the master cylinder)

all is not lost.
__________________
schnauzer power
ShelbyGuy is offline   Reply With Quote
Old 04-29-2007, 03:21 PM   #6
Sharkster's Avatar  
Join Date: Sep 2005
Posts: 633
 
Sharkster's Avatar
 
Join Date: Sep 2005
Posts: 633
Casino cash: $4613300
0.12 per day
Default

I got the fronts tracking straight.
God please tell me I didnt just trash #4 and #8 pistons
I put oil and coolant in after my TT went on. I forgot to burp the block.... on top of that I only put coolant on the resevoir side. I didnt add any coolant to the crossover inlet. I friggin know better than this. Ive been down going on 2 months now and I think Im just in a hurry to get this thing on the road. I dont want to end up with a car in my garage for the entire summer.
Anyhow, last night Im looking through the boards and stumble across a thread about burping the block. Im thinking wait did I burp the block.... OMG I didnt burp the block. I check the oil and most of my oil is gone.... WTF. We have a fluid theif in the garage or what.
Ive lost a little to the small leak on the timing cover and maybe some to the turbos but WOW. OK I top off the oil and drop some 50/50 coolant into the crossover (it took 1 1/2 gallons oh shit) and let here run for a while.
It started and ran with the idle at about 1500 for a minute or 2 and then dropped to about 800-900rpms. OK so coolant levels control the idle now or is causing something else to happen thats not and the car thinks it is and adjusts accordingly?

Now Ive got something that sounds horribly loose under the car probably at or around the K member and I can hear the exhaust hitting the K member as well as the rear axle somewhere
Sharkster is offline   Reply With Quote
Old 04-29-2007, 04:55 PM   #7
Painter's Avatar  
Join Date: Mar 2004
Posts: 1,166
 
Painter's Avatar
 
Join Date: Mar 2004
Posts: 1,166
Casino cash: $4610000
0.21 per day
Default

Quote:
Originally Posted by Sharkster
I got the fronts tracking straight.
God please tell me I didnt just trash #4 and #8 pistons
I put oil and coolant in after my TT went on. I forgot to burp the block.... on top of that I only put coolant on the resevoir side. I didnt add any coolant to the crossover inlet. I friggin know better than this. Ive been down going on 2 months now and I think Im just in a hurry to get this thing on the road. I dont want to end up with a car in my garage for the entire summer.
Anyhow, last night Im looking through the boards and stumble across a thread about burping the block. Im thinking wait did I burp the block.... OMG I didnt burp the block. I check the oil and most of my oil is gone.... WTF. We have a fluid theif in the garage or what.
Ive lost a little to the small leak on the timing cover and maybe some to the turbos but WOW. OK I top off the oil and drop some 50/50 coolant into the crossover (it took 1 1/2 gallons oh shit) and let here run for a while.
It started and ran with the idle at about 1500 for a minute or 2 and then dropped to about 800-900rpms. OK so coolant levels control the idle now or is causing something else to happen thats not and the car thinks it is and adjusts accordingly?

Now Ive got something that sounds horribly loose under the car probably at or around the K member and I can hear the exhaust hitting the K member as well as the rear axle somewhere



Call John, don't go any further untill you guys get together......he's a pro at all the little odds and ends, which are extremely crucial at this point. I have seen motors blow because of small odds and ends being overlooked or forgotten


Ray
Painter is offline   Reply With Quote
Old 05-04-2007, 03:03 PM   #8
Sharkster's Avatar  
Join Date: Sep 2005
Posts: 633
 
Sharkster's Avatar
 
Join Date: Sep 2005
Posts: 633
Casino cash: $4613300
0.12 per day
Default

Quote:
Originally Posted by Painter
Call John, don't go any further untill you guys get together......he's a pro at all the little odds and ends, which are extremely crucial at this point. I have seen motors blow because of small odds and ends being overlooked or forgotten


Ray
John came up and looked the car over.
He put the propane torch to it and didnt find anything. He started messing with the wiring on the IAC and noticed that it would whistle and suck air when he tugged on the wire. Pulled the IAC off and swapped the 99 one for an 03 he brought with him. Seems that IAC is a little faulty. Resealed it and the idle seems to kick down now as normal. Looked over the stats on the predator tune and all looks pretty smooth.
Thanks a bunch John (hoofnit1) guy knows his shit folks.

Valve cover is coming off now. John I have to drain that coolant to get that heater core hose off at the firewall. That passenger side valve cover will not come off with it there. (and I just finished 4 days of burping this pig)
I have to get some header wrap and wrap all of the piping.
Ive taken it out twice now for a couple of short runs. I dont know what scares me more, getting thrown back in my seat or hearing those things spool up and dump.... scared the shit out of me. This thing is absolutely crazy fast and Im just dumping off of the wastegate springs. The EBC isnt programmed yet and Kurgan hasnt worked his magic on my SCT chip yet.

I think some SLP LM 1's are going to go on.
Sharkster is offline   Reply With Quote
Old 05-04-2007, 03:19 PM   #9
Painter's Avatar  
Join Date: Mar 2004
Posts: 1,166
 
Painter's Avatar
 
Join Date: Mar 2004
Posts: 1,166
Casino cash: $4610000
0.21 per day
Default

I would wait a bit before you get on it, I did but it was real hard.......
Painter is offline   Reply With Quote
Old 05-04-2007, 07:23 PM   #10
01Sleeper's Avatar  
Join Date: Dec 2004
Posts: 3,333
 
01Sleeper's Avatar
 
Join Date: Dec 2004
Posts: 3,333
Casino cash: $11143800
0.62 per day
Default

You shouldn't have to disconnect anything to get the valve cover off, it just takes some patience to do. I did mine in my driveway without draining the coolant, or removing the brake booster for the driver side. Good luck and be patience.

Quote:
Originally Posted by Sharkster
John came up and looked the car over.
He put the propane torch to it and didnt find anything. He started messing with the wiring on the IAC and noticed that it would whistle and suck air when he tugged on the wire. Pulled the IAC off and swapped the 99 one for an 03 he brought with him. Seems that IAC is a little faulty. Resealed it and the idle seems to kick down now as normal. Looked over the stats on the predator tune and all looks pretty smooth.
Thanks a bunch John (hoofnit1) guy knows his shit folks.

Valve cover is coming off now. John I have to drain that coolant to get that heater core hose off at the firewall. That passenger side valve cover will not come off with it there. (and I just finished 4 days of burping this pig)
I have to get some header wrap and wrap all of the piping.
Ive taken it out twice now for a couple of short runs. I dont know what scares me more, getting thrown back in my seat or hearing those things spool up and dump.... scared the shit out of me. This thing is absolutely crazy fast and Im just dumping off of the wastegate springs. The EBC isnt programmed yet and Kurgan hasnt worked his magic on my SCT chip yet.

I think some SLP LM 1's are going to go on.
01Sleeper is offline   Reply With Quote
Old 05-05-2007, 04:32 PM   #11
Sharkster's Avatar  
Join Date: Sep 2005
Posts: 633
 
Sharkster's Avatar
 
Join Date: Sep 2005
Posts: 633
Casino cash: $4613300
0.12 per day
Default

I got it. I had to take off the upper intake and loosen the fuel rails. Pushed the wiring harness out of the way, pushed down on the AC line a little and wiggled it out. Put a little chip on the inside. Yes I recovered the chip between the valves.
What is the concensus on the gasket?
Get new gasket and load it up with RTV at the timing cover joints or fill the groove with RTV and dont use a gasket and let it setup for a while and throw it back together.

I read on another site of a guy that used brake cleaner in the groove to degrease it. Filled the groove with RTV and laid the new gasket into the groove and let it setup for 2 days. Put a dab of RTV on the 2 joint areas and then hand tightened it, let it set for several hours then torqued it to 10 pounds.
Sharkster is offline   Reply With Quote
Old 05-06-2007, 09:00 AM   #12
01Sleeper's Avatar  
Join Date: Dec 2004
Posts: 3,333
 
01Sleeper's Avatar
 
Join Date: Dec 2004
Posts: 3,333
Casino cash: $11143800
0.62 per day
Default

I just reused the gasket and used rtv wherever it was originally used. Be careful when you reinstall it, don't push too much on the ac lines, thats how I broke mine. I pushed a little too hard and it just cracked and sprayed everywhere.

Quote:
Originally Posted by Sharkster
I got it. I had to take off the upper intake and loosen the fuel rails. Pushed the wiring harness out of the way, pushed down on the AC line a little and wiggled it out. Put a little chip on the inside. Yes I recovered the chip between the valves.
What is the concensus on the gasket?
Get new gasket and load it up with RTV at the timing cover joints or fill the groove with RTV and dont use a gasket and let it setup for a while and throw it back together.

I read on another site of a guy that used brake cleaner in the groove to degrease it. Filled the groove with RTV and laid the new gasket into the groove and let it setup for 2 days. Put a dab of RTV on the 2 joint areas and then hand tightened it, let it set for several hours then torqued it to 10 pounds.
01Sleeper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
no new posts