Forum Register TCG Mobile Casino Live Posting Feed Garage Arcade Members List Calendar Search Today's Posts Mark Forums Read
Go Back   The Chicago Garage > The Garage > TCG Technical > The Blue Oval

User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-06-2015, 04:10 PM   #1
DJ
Forum Sponsor
 
DJ's Avatar
 
Join Date: Oct 2005
Posts: 1,030
Casino cash: $7009325
0.21 per day
Default Bad Ford Racing plug wire

Anyone else have a bad set of Ford Racing wires? I have had a set on my car for years with no issues. My headers put some burn marks in them so I wanted to replace them. Ever since I put these new ones on they keep falling off. They feel like they go on right but in the middle of driving they fucking fall off. It is getting on my last nerve. I've used dielectric grease and even crushed the connectors a little.
__________________
94 Mustang GT - not stock
08 Jeep Grand Cherokee - OME lift
03 Ford Expedition - Tow Rig
Big Stickers and Signs - Owner
844-399-7274
DJ is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.0.6 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
no new posts